Error code? (web)

beckgarrett's Avatar


04 Apr, 2012 04:16 PM

Hey guys,

I'm having some trouble connecting to the Keyserver, I believe. When I create a new key, I get a "Send keys failed! Code = 0" error window. Just wondering if I could get some help resolving this... I tried Googling but none of the posted fixes worked for me. Thank you!

  1. Support Staff 1 Posted by Steve on 04 Apr, 2012 04:53 PM

    Steve's Avatar

    Sounds like a bug we squashed just recently. Could you please try our nightly version of the GPGTools Installer from here: and let us know if that fixes your problem?

    All the best :)

  2. 2 Posted by beckgarrett on 04 Apr, 2012 06:49 PM

    beckgarrett's Avatar


    I actually saw that suggestion last night, and tried with the nightly version to no avail. I'll give it a second shot though. (:

     I also tried the various Keyservers from here ( and had no luck.

    Additionally, I'm still running Snow Leopard (10.6.8), but if you think an upgrade to Lion would help, I have it (I just haven't installed) and I can try that. I only mention this because I saw this error a lot with people who were running OS X 10.6.8.

    Thanks so much for the prompt response!


  3. Support Staff 3 Posted by Luke Le on 04 Apr, 2012 06:51 PM

    Luke Le's Avatar

    Hi Rebecca,

    Updating to Lion can't hurt, you'll also get the new GPGMail version which integrates nicely into

    But to solve the problem at hand, is there any chance you're behind a very restrictive firewall?

    We've seen this problem with some of our users and there is an easy way around that.

    Hope that helps!

  4. 4 Posted by beckgarrett on 04 Apr, 2012 07:25 PM

    beckgarrett's Avatar


    No, I'm not behind a restrictive firewall, I'm on my home internet.

    Is there anything I'm doing wrong? I can create keys easily enough, just not upload them. My keyserver under System Preferences is, because I've heard others had good luck with it. I admit to being new to GPG, and I've installed everything from the nightly link... With the nightly link install, rather than the main site download, I get a more specific error code... I've attached it, in case it could help?

    Thanks again. (:


  5. Support Staff 5 Posted by Luke Le on 04 Apr, 2012 07:26 PM

    Luke Le's Avatar

    Oh wow, that sure is a strange error.
    Could you please try to install this new MacGPG2 version:

    It's a very early test version but seems to work without problems for some.

    Maybe it fixes your issue.

  6. 6 Posted by beckgarrett on 04 Apr, 2012 07:38 PM

    beckgarrett's Avatar

    Re-installed via your provided link and received the following error code.

    Refresh keys failed!
    Code = 0

    Error text:
    gpg: refreshing 1 key from hkp://
    gpg: requesting key 3406A2B4 from hkp server
    gpg: no handler for keyserver scheme `hkp'
    gpg: keyserver refresh failed: Keyserver error

    Thanks for your help (:

  7. Support Staff 7 Posted by Luke Le on 04 Apr, 2012 07:40 PM

    Luke Le's Avatar

    Hmm... please check something for me.

    Open and type the following line and press enter.

    ls -l /usr/local

    and post the output here.

  8. 8 Posted by beckgarrett on 04 Apr, 2012 07:48 PM

    beckgarrett's Avatar

    This is the text I got back

    ls -l /usr/local
    total 0
    drwxr-xr-x 6 root wheel 204 Apr 3 09:45 MacGPG2
    drwxr-xr-x 5 root wheel 170 Apr 4 15:33 bin

  9. Support Staff 9 Posted by Luke Le on 04 Apr, 2012 11:20 PM

    Luke Le's Avatar

    Ok, that looks fine, but I could just reproduce your problem.
    Will look into that more closely tomorrow.

  10. 10 Posted by dj on 05 Apr, 2012 01:54 AM

    dj's Avatar

    i am having the very same problem. Also on home internet, no key servers will work. Any solutions yet?

  11. 11 Posted by beckgarrett on 05 Apr, 2012 02:27 AM

    beckgarrett's Avatar

    Not yet, but Luke Le said he'd brainstorm and check back tomorrow. Good luck to us all!

  12. Support Staff 12 Posted by Steve on 09 Apr, 2012 01:35 PM

    Steve's Avatar

    Hey Beck and dj,

    could you please test the latest nightly (yet again)?

    First try the GPGTools Installer. If that does not solve your problem please try to install the nightly build of MacGPG2.

    Find both here:

    Let us know if that solves your problem.

    Happy easter to you, enjoy your holidays :)


  13. 13 Posted by beckgarrett on 09 Apr, 2012 02:08 PM

    beckgarrett's Avatar

    The GPGTools re-install seems to have worked for me! No errors when sending and updating from the Keyserver. (:

    Yay! I hope you had a good holiday as well! Thanks so much for all your help.

  14. Support Staff 14 Posted by Steve on 09 Apr, 2012 02:11 PM

    Steve's Avatar

    Yippie :)

    That's good news.

    Off to eating some chocolate eggs now,

  15. Steve closed this discussion on 15 Apr, 2012 12:26 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac