MacGPG: pinentry-mac: Cannot paste into pinentry anymore?

cro's Avatar


22 Oct, 2021 04:47 PM

So this morning, I realized I could not copy my passphrase from 1Password and paste it into pinentry-mac anymore. Command-V just doesn't do anything, no beep or other indicator that something should be happening either.

I validated that I did have the passphrase on my clipboard, and also tried other clipboard contents, but nothing would paste.

The strange thing is that I don't remember doing anything in the past day or so that would have changed the configuration of my system. No updates to the GPGTools suite, no OS updates, nothing from MacPorts that would make a difference.

Rebooting the machine does not help. In the meantime I am resorting to pinentry-curses, but this won't work well with the IDEs I use.


  1. Support Staff 1 Posted by Steve on 25 Oct, 2021 11:33 AM

    Steve's Avatar

    HI cro,

    we are not aware of such a problem.

    Could you please download and install our latest hotfix GPG Suite and see if that solves your problem.

    All the best,

    Disclaimer: Hotfixes are GPG Suite builds containing our latest source code, so bugs and crashes may occur.

  2. 2 Posted by cro on 25 Oct, 2021 03:22 PM

    cro's Avatar

    So I decided to switch back to the GUI version from the curses version before installing the hotfix in case the problem fixed itself (I had rebooted before, as well as tried numerous other troubleshooting steps). Lo and behold, I can paste again, even though I had changed nothing. Sorry to have troubled you, if it crops up again I will install the hotfix version and (re)open an issue.

  3. Support Staff 3 Posted by Steve on 25 Oct, 2021 04:22 PM

    Steve's Avatar

    That is good news. Although it makes it very hard to understand what went wrong in the first place. Please keep an eye on this and don't hesitate to ping if you encounter further glitchiness.

  4. Steve closed this discussion on 25 Oct, 2021 04:22 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac