GPG Mail: After 10.15.4 update, GPG plugin stays unchecked in

Charles's Avatar


08 Apr, 2020 12:07 AM

After updating computer to 10.15.4, GPGMail does not load in Going to Mail -> Preferences -> Manage Plug-in, it shows GPGMailLoader.mailbundle as unchecked. When checking box and clicking Apply and Restart Mail, mail restarts but the box remains unchecked and GPGMail continues not to work. GPG Suite loads okay in System Preferences, says version is up to date. GPG Keychain also loads okay. Tried uninstall GPG Suite and re-installing, same result.

GPGMail to load in, to decode encrypted messages

macOS                   10.15.4     19E266
GPG Suite               2019.2      2670    (ac945f92b0)
GPG Mail                4.0         1515    (597c8f5250)    Decrypt Only Mode
GPG Keychain            1.5.1       1587    (967419866a)
GPG Services            1.12.1      1100    (2d6c8340f0)
MacGPG                  2.2.17      940     (4ba83bbeda)
GPG Suite Preferences   2.2.1       1136    (378dbebf37)
Libmacgpg               1.0.1       924     (ed76f66a8a)
pinentry           16      (9b8e20e2c0)
  1. Support Staff 1 Posted by Steve on 08 Apr, 2020 05:25 PM

    Steve's Avatar

    Hi Charles,

    we apologize for the bad experience. What you describe is unrelated to any issues with your support plan, but rather a bug in macOS Mojave/Catalina which sometimes prevents plugins from loading due to faulty permissions.

    In order to fix that, please follow these steps:

    The solution is to enable Full Disk Access and after that running a Terminal command.


    1. Close
    2. Open System Preferences › Security › Privacy
    3. Enable Terminal under Full Disk Access
    4. Restart Terminal when prompted
    5. Run the following command:

      rm -rf ~/Library/Containers/

    6. Open Mail

    If that doesn’t help, you will have to disable SIP and run step 5 again.

    Hope that helps.

  2. 2 Posted by Charles on 08 Apr, 2020 05:55 PM

    Charles's Avatar

    Thank you very much! This fix did indeed solve the problem, the plugin loaded, and can now read/write encrypted emails as normal. (for future troubleshooting, in this particular case, I did not have to do the extra step of disabling SIP)

    Greatly appreciate the quick response!

  3. Support Staff 3 Posted by Steve on 08 Apr, 2020 09:07 PM

    Steve's Avatar

    Hey Charles,

    glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  4. Steve closed this discussion on 08 Apr, 2020 09:07 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac