GPG Mail: Cannot activate GPG plugin in Mail (Catalina 10.15.2)

Luc Lalonde's Avatar

Luc Lalonde

19 Dec, 2019 09:40 PM

Dear Sir,

I’ve followed the instructions to activate GPGMail in MacOS Catalina Mail. However, the plugin will not activate (Mail, Preferences, Manage plugins, activate GPGMail, restart Mail).

I used your uninstall tool and then re-installed the 2019.2 version… Still can’t use GPGMail.

Thank You!

After having followed the installtion/activation instructions, I expect GPGMail to work.

Additional info
I also get an automated message from GPG-Tools saying that something went wrong when I try to register:


unfortunately it appears that the "Activate" button in your GPG Mail Support Plan Activation Instructions email doesn't seem to work in your case.
This might be, because you are not using the latest version of GPG Suite.

Please download and install GPG Suite 2019.2 directly from

If the "Activate" button from the activation instructions email still doesn't work, it appears that in your case macOS Mail is not configured as standard Mail program which is the reason why the "Activate" link opened a new email instead of interacting with GPG Mail directly.

In order to activate your GPG Mail Support Plan, please press the "Activate" button "Mail › Preferences › GPG Mail". If GPG Mail doesn’t appear in "Mail › Preferences", you might have to enable it first in "Mail › Preferences › Manage Plug-ins…"

As an alternative you can change your default Mail program in "Mail › Preferences › General" and click on the "Activate" button in the activation instructions email again.


Your GPG Tools Support Team

P.S.: This is an automated response. If you need assistance, please contact us at [email blocked]

macOS                   10.15.2     19C57
GPG Suite               2019.2      2670    (ac945f92b0)
GPG Mail                4.0         1515    (597c8f5250)    Decrypt Only Mode
GPG Keychain            1.5.1       1587    (967419866a)
GPG Services            1.12.1      1100    (2d6c8340f0)
MacGPG                  2.2.17      940     (4ba83bbeda)
GPG Suite Preferences   2.2.1       1136    (378dbebf37)
Libmacgpg               1.0.1       924     (ed76f66a8a)
pinentry           16      (9b8e20e2c0)
  1. Support Staff 1 Posted by Luke Le on 20 Dec, 2019 09:55 AM

    Luke Le's Avatar

    Hi Luc,

    we apologize for the inconvenience.
    What you are seeing is a bug in macOS Catalina which sometimes "forgets" to load plugins after they have been activated.

    To fix this problem, please follow these steps:

    1. Close
    2. Open System Preferences › Security › Privacy
    3. Enable Terminal under Full Disk Access
    4. Restart Terminal when prompted
    5. Run the following command:

      rm -rf ~/Library/Containers/

    6. Open Mail

    If you are seeing the error "Operation not permitted", you will have to temporarily disable SIP:

    After that, please repeat step 5.

    Hope that helps.

  2. 2 Posted by Luc Lalonde on 20 Dec, 2019 12:15 PM

    Luc Lalonde's Avatar

    Great! This worked. However, I couldn't remove the Datavaults directory without a 'sudo'. Thanks for the help.

  3. Support Staff 3 Posted by Luke Le on 20 Dec, 2019 12:16 PM

    Luke Le's Avatar

    Oh, of course. Sorry for that.
    Glad to hear though, that it works now.

    Closing this discussion. Feel free to open a new one at any time should you have questions or run into problems.

  4. Luke Le closed this discussion on 20 Dec, 2019 12:16 PM.

  5. Steve closed this discussion on 09 Mar, 2020 06:18 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac