GPG Mail: Signing with S/MIME no longer possible

jan.weinschenker's Avatar


17 Dec, 2019 11:46 AM

Hi all,

sometimes I need to sign my emails with S/MIME and not with GPG. Currently, with GPGTools installed, all outgoing mails are signed with GPG regardless of the setting of the dropdown in the „New Mail“ dialogue.

If I set the dropdown to OpenPGP, the mail is signed with GPG. And if I set the dropdown to S/MIME, the mail is also signed with GPG.

The mail should be signed with the S/MIME certificate, if the dropdown has been set to S/MIME.

macOS                   10.15.2     19C57
GPG Suite               2019.2      2670    (ac945f92b0)
GPG Mail                4.0         1515    (597c8f5250)    Decrypt Only Mode
GPG Keychain            1.5.1       1587    (967419866a)
GPG Services            1.12.1      1100    (2d6c8340f0)
MacGPG                  2.2.17      940     (4ba83bbeda)
GPG Suite Preferences   2.2.1       1136    (378dbebf37)
Libmacgpg               1.0.1       924     (ed76f66a8a)
pinentry           16      (9b8e20e2c0)
  1. Support Staff 1 Posted by Steve on 19 Dec, 2019 12:08 AM

    Steve's Avatar

    Hi Jan,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    This issue has been fixed. If you want to test the fix, please download our latest hotfix GPG Suite.


    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected.

  2. 2 Posted by jan.weinschenke... on 23 Jan, 2020 12:02 PM

    jan.weinschenker's Avatar

    Hi Steve,

    Hotfix has solved the issue, thanks!


  3. Support Staff 3 Posted by Luke Le on 23 Jan, 2020 04:48 PM

    Luke Le's Avatar

    Hi Jan,

    great to hear that. Thank you for the update.

    Closing this discussion. Feel free to open a new one at any time should you have questions or run into problems.

  4. Luke Le closed this discussion on 23 Jan, 2020 04:48 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac