GPG Keychain: password prompt

greg's Avatar


23 Sep, 2019 02:24 PM

Up until now GPG has always asked for my password anytime I encrypt or decrypt. However it suddenly now longer asks for my password and will encrypt or decrypt anything without asking for my password. What did I do?

Ask for password

macOS                   10.14.6     18G95
GPG Suite               2019.1      2539    (f7527f7dd4)
GPG Mail                3.2.1       1388    (4319271f53)    30 trial days remaining
GPG Keychain            1.5         1577    (6daf90a76b)
GPG Services            1.12        1096    (17b325bb15)
MacGPG                  2.2.17      938     (cb13729b0b)
GPG Suite Preferences   2.2         1115    (f813be50a8)
Libmacgpg               1.0         920     (b50a3b4b50)
pinentry           14      (c191c4128d)
  1. Support Staff 1 Posted by Steve on 23 Sep, 2019 02:31 PM

    Steve's Avatar

    Hi Greg,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    This sounds like the password for your OpenPGP key may have been stored in macOS keychain.

    Please see this KB-article on how to manage passwords for your keys.

    If you clear stored passwords, are you then again asked for your password? If you prefer this setup, please make sure to untick the option to store your passwords in macOS keychain in System Preferences > GPG Suite > Settings.

    All the best,

  2. 2 Posted by Greg on 23 Sep, 2019 04:57 PM

    Greg's Avatar


    Thanks for the prompt reply. I actually figured this out myself! Thanks for
    confirming what i thought might have been the problem.


  3. Support Staff 3 Posted by Steve on 30 Sep, 2019 10:54 AM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  4. Steve closed this discussion on 30 Sep, 2019 10:54 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac