GPG Mail: OpenPGP button greyed out. Encrypt and Sign buttons not visible.

lmuraro's Avatar


18 Sep, 2019 12:33 AM

Which of our tools is giving you problems? GPGMail 3.2.1 Build 1388

Attach a screenshot of the version info for all installed components (how to:

Describe your problem. Add as much detail as possible. I've installed GPG Tolls for Mac sucessuflly.
I have enabled GPG Mail and it shows GPG Mail Ready in Mail -> Preference -> GPG Mail.
I have created my keys and signed them .
I have obtained correspondents public keys and signed them.
When I create a new Mail message and address it to a users that I have a public key for, the OpenPPG button is grayed out. The Encrypt and Sign buttons are not shown.

I have tried to rm the DataVaults folder as suggested in other posts but;

sudo rm -rf ~/Library/Containers/
does not work:
rm: /Users/george/Library/Containers/ Operation not permitted

When I look inside the Data folder at DataVaults, I cannot get info for the file.

What did you expect instead

Describe steps leading to the problem.

Are you using any other plugins? No.

  1. Support Staff 1 Posted by Steve on 18 Sep, 2019 12:23 PM

    Steve's Avatar

    Hi lmuraro,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    For your keys to be recognized correctly by GPG Mail it is important to double check that the email used in the key does perfectly match the email used in Mail > Preferences > Accounts. In this case capital letters do matter. Could you verify everything is ok in that regard?

    If you think everything is in order and are still unable to resolve this problem, please send a debug log from your affected machine: Open System Preferences > GPG Suite > Send Report. Check the box to "attach debug log". Since you already described your issue in this discussion, you don't need to add a lot of detail, but please do add the link to your existing discussion, so I can then merge your debug info with this existing discussion.

    All the best,

  2. 2 Posted by lmuraro on 20 Sep, 2019 12:41 AM

    lmuraro's Avatar

    I'm sorry to have troubled you. The reason the OpenPGP button was greyed out and the Encrypt and Sign buttons were missing is that I forgot to change the sending account to the one that has PGP keys

  3. lmuraro closed this discussion on 20 Sep, 2019 12:41 AM.

  4. Steve re-opened this discussion on 20 Sep, 2019 01:17 PM

  5. Support Staff 3 Posted by Steve on 20 Sep, 2019 01:17 PM

    Steve's Avatar

    No problem.

    This KB-article explains how to add more than one email address to an existing key. The email addresses in a key are called userIDs and you can add as many as you want. You can of course also create an additional key for the other email address.

    Important note: Note that all email addresses you add to a single key can be connected to one identity. Depending on your use-case this might be wanted or should be avoided. Please consider that first and then proceed.

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  6. Steve closed this discussion on 20 Sep, 2019 01:18 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac