GPG Keychain/GPG Suite Preferences Very Slow to Open on macOS​ Mojave

sakibk+gpg's Avatar


21 Jul, 2019 06:42 AM

This post refers to GPG Keychain/GPG Suite Preferences for Mac 2018.5

Hello, just did a clean install of Mojave (10.14.5) and installed the latest GPG Suite (2018.5). I imported my keys from my other machine (also macOS Mojave 10.14.5). GPG Keychain and the GPG Suite Pref pane takes about 5 minutes to open (on both machines), as does the GPG Suite preferences pane. Once the preferences pane opened I did disable the "Automatically download public keys" option in case it was trying to query the key server. This made no difference (even after a machine restart). I also deleted some old expired public keys. The GPGPMail plugin is installed in Mail (and has been enabled - under 30-day trial currently).

Any ideas on what I can do to solve or troubleshoot this problem? Thanks in advance!

  1. 1 Posted by paul on 21 Jul, 2019 09:26 AM

    paul's Avatar

    I am running Macbook Air 6,2
    GPG_Suite-20191b1 (Beta)

    Took 5 minutes for me to load GPG
    Took 5 minutes to load System Preferences--> GPG Suite

  2. Support Staff 2 Posted by Steve on 22 Jul, 2019 08:34 AM

    Steve's Avatar

    Hi sakibk,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you please send a debug log from your affected machine: Open System Preferences > GPG Suite > Send Report. Check the box to "attach debug log". Since you already described your issue in this discussion, you don't need to add a lot of detail, but please do add the link to your existing discussion, so I can then merge your debug info with this existing discussion.

    All the best,

  3. 3 Posted by sakibk+gpg on 25 Jul, 2019 07:13 AM

    sakibk+gpg's Avatar

    Hi Steve

    The debug report was submitted. Looking forward to your reply.

  4. Support Staff 4 Posted by Steve on 26 Jul, 2019 08:47 AM

    Steve's Avatar

    Hi sakibk,

    from your description, you might be affected by a recent attack on the old key servers. In that attack public keys are flooded with signatures leading to problems for gpg when processing those keys.

    We are working on a fix for this and will be the new default key server which is not affected by this attack. Our nightly build includes MacGPG 2.2.17 which mitigates this attack by no longer downloading key signatures.

    To get back to working state for your specific setup, please download and install our latest hotfix GPG Suite.

    Open GPG Keychain. If it doesn't open right away, you may be affected by this attack. To deleted flooded keys:

    • open (easy to find via Spotlight)
    • copy paste the following command and press enter to execute:
    gpg --delete-keys C4BC2DDB38CCE96485EBE9C2F20691179038E5C6 CC11BE7CBBED77B120F37B011DCBDC01B44427C7 4F9F89F5505AC1D1A260631CDB1187B9DD5F693B

    That will remove the problematic keys. Here is a list of keys we are aware of that have been affected by the flooding attack:

    [email blocked] C4BC2DDB38CCE96485EBE9C2F20691179038E5C6
    [email blocked] CC11BE7CBBED77B120F37B011DCBDC01B44427C7
    [email blocked] 4F9F89F5505AC1D1A260631CDB1187B9DD5F693B

    You can then re-download the public key in question since you are now protected from this attack, as the nightly build has steps to mitigate it. Those fixes will be included in the upcoming release which we are still working on.

    We have two KB articles covering this:

    All the best,

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  5. 5 Posted by sakibk+gpg on 26 Jul, 2019 10:00 AM

    sakibk+gpg's Avatar

    Hi Steve,

    It seems this solved the problem.

    I download 2019.1 (2466n). During the installation, the installer got stuck for a few minutes on "Running Package Scripts". Then it proceeded to install. After installation both GPG Keychain and GPG Preferences took about 5 mins to open. I then proceeded to enter the terminal and delete the keys as per your advice below. The only key that was in the key chain was:

    [email blocked] 4F9F89F5505AC1D1A260631CDB1187B9DD5F693B

    I needed to enter the delete command for each individual key.

    It took about 7 mins for the key to be deleted and during this time GPG was using about 96% CPU time.

    On restarting GPG Keychain and GPG Suite preferences they both opened immediately.

    Thank you for your help.

  6. Support Staff 6 Posted by Steve on 26 Jul, 2019 10:39 AM

    Steve's Avatar

    Thanks for the feedback. I changed the order of the fixing steps as removing the affecte keys first should prevent a hang during installation and the long opening times for GPG Suite Preferences and GPG Keychain.

    What happened when you issued the command with all fingerprints (issue the command as is in a single line)? Asking since you write you had to issue the command for each individual key. Tested it here and it worked with issuing just a single command.

    I added a note about the CPU spikes that can happen and that those are expected.

    Could you now re-install the nightly build again and let me know if you are still seeing that long wait during installation?

    Kind regards,

  7. 7 Posted by sakibk+gpg on 26 Jul, 2019 04:08 PM

    sakibk+gpg's Avatar

    Hi Steve,

    This post relates to my second mac that was also showing the same issues as the first mac.

    By changing the order of your instructions [delete keys first] as per your last message the install of 2019.1 (2466n) does not get stuck on "Running Package Scripts".

    Regarding the deleting of the keys.

    If I issue the command to delete all three keys as per your instructions then since the first key is not installed I get the error:

    gpg: key "C4BC2DDB38CCE96485EBE9C2F20691179038E5C6" not found: Not found
    gpg: C4BC2DDB38CCE96485EBE9C2F20691179038E5C6: delete key failed: Not found

    The operation then returns to the command prompt. Therefore, I issued the delete command for each key. Only the third key was installed. On issuing the command the system hangs for about 10 minutes before the confirmation to delete the key appears.

    I hope this helps.

  8. Support Staff 8 Posted by Steve on 26 Jul, 2019 04:16 PM

    Steve's Avatar

    Ok, that's expected and valuable feedback as when I tested the command I had all three keys in GPG Keychain.

    Good to hear both systems are now again operational.

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  9. Steve closed this discussion on 26 Jul, 2019 04:16 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac