GPGMail plugin (eb3c5ff0) broke on the latest 10.14.1 beta (18B57c)

anthony.gelibert's Avatar


10 Oct, 2018 07:59 AM

Since (Version 12.1 (3445.100.42)), GPGMail crashes the application (and I'm sure it's this plugin, cause everything works when I disable it):

Nom de l’exception : NSInvalidArgumentException
Description : -[MUIWebDocument setBlockRemoteContent:]: unrecognized selector sent to instance 0x600001951780
Informations sur l’utilisateur : (null)

0 CoreFoundation 0x00007fff310ebe65 exceptionPreprocess + 256
1 libobjc.A.dylib 0x00007fff5d137720 objc_exception_throw + 48
2 CoreFoundation 0x00007fff3116922d -[NSObject(NSObject) _retain_OA] + 0
3 CoreFoundation 0x00007fff3108d820 _
_ + 1486
4 CoreFoundation 0x00007fff3108d1c8 CF_forwarding_prep_0 + 120
5 GPGMail 0x0000000109fef497 GPGMail + 296087
6 Foundation 0x00007fff33397d83 -[NSObject(NSKeyValueObservingPrivate) _changeValueForKeys:count:maybeOldValuesDict:maybeNewValuesDict:usingBlock:] + 694
7 Foundation 0x00007fff33397ab0 -[NSObject(NSKeyValueObservingPrivate) _changeValueForKey:key:key:usingBlock:] + 68
8 Foundation 0x00007fff33397a4a _NSSetObjectValueAndNotify + 255
9 Mail 0x0000000106181c5b Mail + 1158235
10 Foundation 0x00007fff33398f96 NSKeyValueNotifyObserver + 346
11 Foundation 0x00007fff33398a02 NSKeyValueDidChange + 481
12 Foundation 0x00007fff33397ddf -[NSObject(NSKeyValueObservingPrivate) _changeValueForKeys:count:maybeOldValuesDict:maybeNewValuesDict:usingBlock:] + 786
13 Foundation 0x00007fff33397ab0 -[NSObject(NSKeyValueObservingPrivate) _changeValueForKey:key:key:usingBlock:] + 68
14 Foundation 0x00007fff33397a4a _NSSetObjectValueAndNotify + 255
15 Mail 0x0000000106364d07 Mail + 3136775
16 Foundation 0x00007fff333d4827 __NSBLOCKOPERATION_IS_CALLING_OUT_TO_A_BLOCK
_ + 7
17 Foundation 0x00007fff333d472e -[NSBlockOperation main] + 68
18 Foundation 0x00007fff333a9d5a -[NSOperationInternal _start:] + 686
19 Foundation 0x00007fff333d445f __NSOQSchedule_f + 227
20 libdispatch.dylib 0x00007fff5e1c35c8 _dispatch_block_async_invoke2 + 83
21 libdispatch.dylib 0x00007fff5e1b7dcf _dispatch_client_callout + 8
22 libdispatch.dylib 0x00007fff5e1c2f63 _dispatch_main_queue_callback_4CF + 1125
23 CoreFoundation 0x00007fff31034e8b __CFRUNLOOP_IS_SERVICING_THE_MAIN_DISPATCH_QUEUE
+ 9
24 CoreFoundation 0x00007fff3103459a __CFRunLoopRun + 2335
25 CoreFoundation 0x00007fff31033a28 CFRunLoopRunSpecific + 463
26 HIToolbox 0x00007fff302cc845 RunCurrentEventLoopInMode + 293
27 HIToolbox 0x00007fff302cc57b ReceiveNextEventCommon + 618
28 HIToolbox 0x00007fff302cc2f8 _BlockUntilNextEventMatchingListInModeWithFilter + 64
29 AppKit 0x00007fff2e588f47 _DPSNextEvent + 997
30 AppKit 0x00007fff2e587ce6 -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1362
31 AppKit 0x00007fff2e581d49 -[NSApplication run] + 699
32 AppKit 0x00007fff2e571483 NSApplicationMain + 780
33 libdyld.dylib 0x00007fff5e206011 start + 1
34 ??? 0x0000000000000002 0x0 + 2.

Since now GPGMail has a paying support, can we expect a quick solution? I can no more read/send easily encrypted email and it's mandatory in my job.

Kind regards,

  1. 1 Posted by anthony.geliber... on 10 Oct, 2018 04:46 PM

    anthony.gelibert's Avatar

    I just tried the latest beta (2338) and it didn't solved the problem…

  2. Support Staff 2 Posted by Steve on 17 Oct, 2018 06:06 PM

    Steve's Avatar

    Hi Anthony,

    there is currently a problem on macOS 10.14.1 since Apple introduced quite some big changes in 10.14.1b3. We have a pending ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news. Feel free to open a new discussions should you run into further problems or need assistance.

    This KB-article elaborates on why GPGMail may not work with unreleased macOS updates and what to do if you cannot revert to a stable macOS release.

    Please note that there is no official support for macOS pre-release versions. Should you rely on GPGMail for your productive work, please stick to the stable release channel of macOS.

    In case you think Apple should be having an API for to help staying on top of macOS changes in regards to, don't hesitate to drop them a few lines via their feedback form.

    To temporarily uninstall GPG Mail: This KB-article explains how to uninstall GPGTools or GPG Mail only. You can then use GPG Services as a workaround for the time being.

    We are currently looking at the changes Apple has made in 10.14.1b3 and working on a solution.


  3. Support Staff 3 Posted by Luke Le on 19 Oct, 2018 02:11 AM

    Luke Le's Avatar

    Hi Anthony,

    would you mind downloading and installing our latest hotfix GPG Suite and see if that improves the situation?

    GPG Suite 2349n and later should address this problem.

    It might be necessary to re-activate GPG Mail in Mail › Preferences › Manage Plug-ins after installing the hotfix.

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  4. 4 Posted by anthony.geliber... on 19 Oct, 2018 06:40 AM

    anthony.gelibert's Avatar

    I try…

    At least, it doesn’t crash when I open a ciphered mail…
    I will try to send ciphered and signed emails and see how well it works.


    P.-S. Ciphered drafts are working.

  5. Support Staff 5 Posted by Steve on 19 Oct, 2018 02:05 PM

    Steve's Avatar

    Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  6. Steve closed this discussion on 19 Oct, 2018 02:05 PM.

  7. Steve closed this discussion on 23 Oct, 2018 10:05 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac