"Secret key to decrypt the message is missing." but GPG Keychain has my sec key

tingeber's Avatar


02 May, 2017 01:59 PM

Can't tell. Presumably MacGPG2 and GPGServices.

I am unable to decrypt anything due to "secret key missing", but my secret key is in my keychain. I can see it both in the GPG Keychain, and by doing pgp -K in Terminal. I only have the one pub/sec keypair (with multiple UIDs and a subkey).

I tried decrypting through Mail.app, Thunderbird, Terminal, and the contextual menu. none work.
I can encrypt fine with my public key.

I have been using the Beta on Mac OS Sierra for months without issues. The variable that changed is that I installed the Keybase app, due to Keybase's insistence on switching to the desktop app. Keybase kept erroring out when I tried signing the app with my key (the first step in installing the app) - that is when I stopped being able to decrypt.

I uninstalled Keybase, but it didn't help.
I installed the latest nightly an hour ago, to see if the problem resolves itself, but it didn't.

I am able to decrypt fine on my phone (iPhone 6s) with the ipgMail app - which makes me think some wires crossed in my system after I installed Keybase.

this is my key: http://hkps.pool.sks-keyservers.net/pks/lookup?op=get&search=0x...

What did you expect instead

I expected to decrypt without issues.

Describe steps leading to the problem.

All decrypting processes I could think of fail.

No other plugins.

  1. 1 Posted by tingeber on 02 May, 2017 08:53 PM

    tingeber's Avatar


    • made a backup of my pub/sec key from gpg keychain
    • deleted my pub/sec key from gpg keychain
    • re-imported the pub/sec key into gpg keychain
    • success
  2. Support Staff 2 Posted by Steve on 04 May, 2017 10:07 AM

    Steve's Avatar

    Hi Tin,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    This sounds really obscure. Glad you were able to get back to working state. I still wonder what went wrong in the first place. Have you tried re-installing keybase and see if you are able to use your key with that app? I'd be curious to learn if the problem is reproducible or was a one time glitch.

    Kind regards,

  3. 3 Posted by tingeber on 04 May, 2017 10:27 AM

    tingeber's Avatar

    Hi Steve,
    Yeah a weird one for sure.

    I managed to re-install Keybase through another weird hack: my issue was that Keybase wasn't letting me log in with my PGP secret key, throwing the following error:

    ▶ ERROR ImportKey error: openpgp: invalid data: entity without any identities https://github.com/keybase/client/issues/4213

    The solution was to delete, then re-add some of my UIDs through GPG Keychain. To the best of my Google-based knowledge there's some incompatibility in how pgp2 was formatting results when keybase requested them, and this procedure forced pgp2 to reformat them in a way Keybase was ok with.

  4. Support Staff 4 Posted by Steve on 04 May, 2017 11:06 AM

    Steve's Avatar

    Nice research work!

    You may want to +1 the GitHub keybase issue to raise attention on their side.

    I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Also if you want updates as to when the keybase issue may be solved would be highly welcome, so others can understand the history of this problem.

    Best, steve

  5. Steve closed this discussion on 04 May, 2017 11:06 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac