encryption failed, unusable public key

Jon's Avatar


26 Apr, 2017 03:18 PM

Which of our tools is giving you problems?

GPG Keychain

Attach a screenshot of the version info for all installed components (how to: https://gpgtools.tenderapp.com/kb/faq/where-can-i-find-version-info...):

Describe your problem. Add as much detail as possible.

Received error while trying to send mail. Have been using keychain for several weeks with no problems until this morning. Error code follows:

gpg: F753E7AA87703E690766FA74967C1135C7180578: skipped: Unusable public key
gpg: -&5: encryption failed: Unusable public key
What did you expect instead

To send the encrypted mail as usual.

Describe steps leading to the problem.

Tried to send encrypted mail.

Are you using any other Mail.app plugins?


  1. Support Staff 1 Posted by Steve on 26 Apr, 2017 04:10 PM

    Steve's Avatar

    Hey Jon,

    the error message that "encryption failed" due to an "unusable public key" can be caused by an expired subkey in your own key.

    To find out, if your subkey is expired:

    1. double click your sec / pub key in GPG Keychain
    2. navigate to the "Subkey" tab
    3. check the validity field

    In case your subkey is expired, you can change the expiration date to a date in the future. Your key then should be working again. to test, restart mail.app and send yourself an encrypted and signed mail.

    Don't forget to upload the updated key to the key server (if you want to use them or previously uploaded your public key) and share it among your friends.

    Let me know if that worked,

    Best regards,

  2. 2 Posted by Jon on 26 Apr, 2017 04:38 PM

    Jon's Avatar

    Thank you Steve, it turns out that the public key for one of the recipients had expired. We have generated a new key and all is well. Thank you for your help!

    -Jon Lee

  3. Support Staff 3 Posted by Steve on 26 Apr, 2017 04:40 PM

    Steve's Avatar

    Jon, please note that the old key can be made valid again by simply adjusting the expiry date (even if the key has expired).

    So you may want to consider revoking the new key (upload the revoked version if you uploaded the new key to the key servers already).

    Then change the expire date of the expired key and again if previously uploaded to the key servers, upload the updated version.

  4. Steve closed this discussion on 07 Aug, 2017 05:14 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac