GPGMail and Thunderbird

Alexander Nouak's Avatar

Alexander Nouak

18 Nov, 2021 01:24 PM

Recipients using Thunderbird 78 claim that my mails signed with the latest version of GPGMail in of macOS Monterey are displayed purely blank. Sometimes, the message appears briefly but then seems to be completely empty.

This, so it was reported by respective users, does not happen with earlier versions of GPGMail.

I could verify this behaviour by accessing my mail account with Thunderbird. My own mails in the Sent folder will not be displayed, the messages signed with previous versions of GPGMail are.

Can you confirm this behaviour? Does anybody have an idea what I possibly could do wrong?

Thank you.

Best regards


  1. 1 Posted by matt on 18 Nov, 2021 04:07 PM

    matt's Avatar

    I'm seeing the same thing since I updated to Monterey on Tuesday evening. Wednesday I started getting reports that tbird users were seeing a blank screen for my emails.

    One person reported that notification popups for my mail arriving had content, but that it was then unviewable in the mail client. The same person managed to fix their ability to read my messages by importing my GPG key and beginning to validate my signatures. He had been previously doing GPG but hadn't imported my key.

    Another person was not able to fix things by importing my key, but it's not 100% clear that he's actually validating signatures.

  2. 2 Posted by Alexander Nouak on 18 Nov, 2021 04:12 PM

    Alexander Nouak's Avatar

    Thank you, matt, for your report.

    However, importing the key is not a solution. The signed message should be readable by Thunderbird without having to deal with the rather anything else than intuitive implementation of GPG/PGP into Thunderbird. So my question is: who does not comply to the standards: Mail with GPGMail or Thunderbird?

  3. 3 Posted by matt on 18 Nov, 2021 04:29 PM

    matt's Avatar

    Oh yes.. I agree it should be readable either way. I only included the information to help narrow down troubleshooting.

  4. Support Staff 4 Posted by Luke Le on 18 Nov, 2021 05:42 PM

    Luke Le's Avatar

    Hi Alexander,

    unfortunately it appears that under special circumstances macOS Mail on Monterey adds a Content-Transfer-Encoding header to the top level heaeders with an invalid value. Thunderbird appears to be strictly adhering to the standard and shows an empty message instead.

    A fix for this issue is included in the latest hotfix GPG Suite and will be included in an upcoming release:

    It would be great if you could test the latest hotfix and let us know if that solves the issue for you.

    Thank you!

    Disclaimer: GPG Suite hotfix builds included the latest development source code. Bugs or crashes may occur.

  5. 5 Posted by Alexander Nouak on 19 Nov, 2021 01:48 PM

    Alexander Nouak's Avatar

    Dear Luke!

    Thank you for sharing this pre-release. I did install it and indeed that seemed to help. Emails signed with this version of GPGMail are properly displayed in Thunderbird 78.

    Thank you so much for this rapid fix.

    I hope my experience will be confirmed by other users.

  6. 6 Posted by Olivier Bornet on 19 Nov, 2021 04:05 PM

    Olivier Bornet's Avatar

    Hello Luke,

    Same experience here: your pre-release works now with Thunderbird.

    Thanks for it.

  7. Support Staff 7 Posted by Steve on 19 Nov, 2021 06:06 PM

    Steve's Avatar

    Thanks for your quick feedback and confirming the fix, which will be part of the upcoming bug fix GPG Suite.

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  8. Steve closed this discussion on 19 Nov, 2021 06:06 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac