Big Sur – S/MIME as default over OpenPGP doesn't work anymore

joss.brown's Avatar


04 Feb, 2021 11:27 AM

Hello, I'm on macOS Big Sur (11.2) with Apple Mail 14.0, and it's not possible anymore to set the default encryption & signing method to S/MIME. It was working fine on Catalina before upgrading, and the GPGMail preferences didn't change.

I ran defaults write org.gpgtools.gpgmail DefaultSecurityMethod -int 2 again, just to be sure, but to no avail.

All my S/MIME certificates match up precisely with the e-mail addresses, are valid according to Keychain Access, and go back to a single root CA trusted as a default by macOS.

Is there a workaround?

Thanks in advance for any help. It would be much appreciated.

  1. 1 Posted by joss.brown on 04 Feb, 2021 11:30 AM

    joss.brown's Avatar

    PS: I also tried killall cfprefsd after executing the defaults command, but that didn't help either.

  2. 2 Posted by joss.brown on 04 Feb, 2021 11:36 AM

    joss.brown's Avatar

    I just ran a new test after a reboot… it seems that the DefaultSecurityMethod does work… if it is set to 2, the default encryption & signing method will indeed be S/MIME, but Apple Mail is nevertheless telling me in the "Security Method" dropdown menu that the default method is "OpenPGP".

    So maybe it's a problem with Apple Mail?

  3. 3 Posted by joss.brown on 04 Feb, 2021 11:39 AM

    joss.brown's Avatar

    PS: and this has the consequence that I'm unable to manually switch encryption & signing from S/MIME to OpenPGP, because Mail apparently thinks that OpenPGP is already selected over S/MIME.

  4. Support Staff 4 Posted by Steve on 04 Feb, 2021 04:12 PM

    Steve's Avatar

    Hi Joss,

    welcome to the GPGTools support platform and thanks for taking the time to report this problem.

    This is a known issue in GPG Suite 2020.2. Sadly the default is not respected. As a workaround for the time being you have to switch to S/MIME manually. We are very sorry about this. We hope to have a fix out soon.

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news. Feel free to open a new discussion should you run into further problems or need assistance.

    Kind regards,

  5. Steve closed this discussion on 11 Feb, 2021 11:18 PM.

  6. Support Staff 5 Posted by Steve on 18 Apr, 2021 10:24 AM

    Steve's Avatar

    Hi Joss,

    this issue were the default security method was not respected in GPG Mail has been fixed. If you want to test the fix, please download our latest hotfix GPG Suite. That page also has Signature file and SHA256 to verify the download. Thanks for helping us test this fix.

    Should the problem persist, please do let us know and re-open this discussion.

    Should you see trouble using GPG Suite in the future, don't hesitate to get in touch and open a new discussion any time.

    Have a great weekend & stay safe,

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected.

  7. Steve closed this discussion on 18 Apr, 2021 10:24 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac