GPG Tools tries to connect to a server right after key generation

rpk's Avatar


20 Oct, 2014 07:26 AM

There is one issue which lead a friend of mine to uninstall GPG Tools right after he tried created his first key. "upload key after generation" was unchecked. But right after key generation Little Snitch informed him that GPG Tools, i suppose GPG Keychain in that particular case, tried to connect to an external server. Not a fact to build trust. ;) So why is there a need to connect to a server at all? Best regards Ralf

  1. 1 Posted by Naganu Nanu on 26 Oct, 2014 03:06 PM

    Naganu Nanu's Avatar

    I am curious as to why this is happening. Maybe a staff member could chime it on this?

  2. Support Staff 2 Posted by Steve on 26 Oct, 2014 05:40 PM

    Steve's Avatar

    Hi rpk,

    could you please download and install our latest nightly build and see if the problem persists.

    You can find sig and SHA1 on the GPGTools Nightlies page.

    I tried to reproduce the described behavior but was unable to do so. I opened GPG Keychain, created a new key without ticking the "upload pub key" option. GPG Keychain did not connect to any key server after or during key creation.

    All the best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  3. 3 Posted by rpk on 27 Oct, 2014 03:43 PM

    rpk's Avatar

    Hi Steve. My friend went on vacation two days ago. :/ I will tell him to try the suggested steps as soon as he's back. I will get back to you afterwards. Best regards Ralf

  4. Support Staff 4 Posted by Steve on 27 Oct, 2014 03:45 PM

    Steve's Avatar

    Ralf, perfect. Just send an update once you've tested this.

  5. Steve closed this discussion on 17 Dec, 2014 07:35 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac