not compatible with MailHub ✔ #773, GPGMail

Robert's Avatar


09 Nov, 2014 01:41 PM

I'm using two Mail Plugins: MailHub ( and GPGMail. So far this has never been a problem, but now it seems to be! The MailHub-Plugin adds some Buttons to the Send-Mail-Window where you can select where the sent message should be stored. This Buttons are gone when GPGMail is loaded. Both plugins worked perfectly together in the old Mail version.

  1. 1 Posted by Eduard on 09 Nov, 2014 09:42 PM

    Eduard's Avatar

    Yes, indeed, this is a problem takes place . see attached screenshot .

  2. 2 Posted by Eduard on 09 Nov, 2014 09:46 PM

    Eduard's Avatar

    Yes, indeed, this is a problem takes place . see attached screenshot .

  3. 3 Posted by Robert on 15 Nov, 2014 10:37 AM

    Robert's Avatar

    I posted the same bug report in the MailHub-support forum, here is their answer:

    Hi Robert,

    I tested GPGMail with MailHub, and you are correct: when GPGMail is installed, the MailHub compose-mail toolbar disappears.

    I then tested GPGMail without MailHub, and noticed that the standard formatting toolbar disappears when GPGMail is installed.

    My conclusion is that GPGMail interferes with 'auxiliary toolbars' in general: that is an issue the GPGMail team should address. I see that it's a beta release of GPGMail, so they may already know about the issue.

    Best Regards

  4. 4 Posted by quwax on 16 Nov, 2014 01:45 AM

    quwax's Avatar

    I see the same thing here …

  5. Support Staff 5 Posted by Luke Le on 17 Nov, 2014 05:28 PM

    Luke Le's Avatar

    Hi all,

    we have a test build now for you and it would be great if you could let us know if that fixes this problem.

    1.) Install the GPGMail version attached to this discussion (without uninstalling anything first)
    2.) Run Mail and start writing a new email.
    3.) Let us know if you can see the mailhub toolbar as well as the security indicator in the upper right corner.

    It's possible that GPGMail will prompt you that a new version is available. Please simply ignore that message for now.


  6. 6 Posted by Robert on 17 Nov, 2014 05:57 PM

    Robert's Avatar

    I just tried it and I get the "Your GPGMail beta has expired" message directly when I start Mail. The GPGMail plugin is then not loaded.

  7. 7 Posted by Eduard on 17 Nov, 2014 06:00 PM

    Eduard's Avatar

    Dear Luke Le, I set you provided above version. After starting issued an information window to read:

    "Your GPGMail beta has expired You can no longer use this version of GPGMail. Please visit to download the newest version."

    Therefore the efficiency provided by you to check the version of the program is not possible.

  8. Support Staff 8 Posted by Luke Le on 17 Nov, 2014 06:36 PM

    Luke Le's Avatar

    Damned, terribly sorry for that.
    The version attached to this answer will be working.

  9. 9 Posted by Robert on 17 Nov, 2014 07:13 PM

    Robert's Avatar

    Thank you very much, that seems to work perfectly!

  10. 10 Posted by quwax on 18 Nov, 2014 01:28 AM

    quwax's Avatar

    Thanks :-)
    The second beta looks like working here as well.
    What would be nice, if Mail would be restarted after the installer quit mail for installation.

  11. Support Staff 11 Posted by Luke Le on 18 Nov, 2014 01:39 AM

    Luke Le's Avatar

    Ah, very good to know. Thanks for testing!
    @quwax: sounds like a good idea, if it does it only if it had to quit Mail previously. Will add a ticket. thanks!

  12. 12 Posted by quwax on 19 Nov, 2014 04:08 AM

    quwax's Avatar

    before I update - MacOS nerves already - does this beta work with 10.0.1?

  13. Support Staff 13 Posted by Luke Le on 19 Nov, 2014 06:19 AM

    Luke Le's Avatar

    It does, yes.

  14. Support Staff 14 Posted by Steve on 20 Nov, 2014 11:04 AM

    Steve's Avatar

    This issue is fixed in the source. It will be included in the next beta.

  15. Steve closed this discussion on 20 Nov, 2014 11:04 AM.

  16. Steve re-opened this discussion on 01 Dec, 2014 09:10 PM

  17. Support Staff 15 Posted by Steve on 01 Dec, 2014 09:10 PM

    Steve's Avatar

    Hi Robert,

    this should be fixed by installing GPG Suite beta 3.

    Please let me know if this is the case.


  18. Steve closed this discussion on 02 May, 2015 11:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac