Issues with encrypted drafts when using POP account

gpguser's Avatar


26 Mar, 2015 03:19 PM

Dear GPG team,
I'm a new GPG user and I really like your work!

But from the day I installed GPG-Tolls, drafts from replying a message are saved in the conversation feed and are not deleted after the mail was send.

This ist not just for encrypted or signed mails but for every mail, if I reply to a message.

But drafts of a message should be just saved in the mailbox "Drafts" if they are not send.
Before the Beta 5 version every saved state of the draft was saved as a single mail in the feed, now its just the latest version of the draft.

Therefore, I realize that you are working on this issue, but its still not fixed.

A friend of mine who is also new to GPG-Tolls reports the same problem.

Im using:
- GPGMail 2.5b5 (73f5ff7) 894n - POP3 - "Encrpyt drafts" is activated - Mail Version 7.3 (1878.6) on Mavericks 10.9.5

Thanks for your work and I'm hoping for an update!

  1. Support Staff 1 Posted by Steve on 27 Mar, 2015 06:32 PM

    Steve's Avatar

    Hi there,

    pop is some interesting stuff. I just spend 40 minutes experimenting with a pop account. Having GPGMail active, then disabling GPGMail (by removing the bundle). I was not able to find any pattern to reliable reproduce this problem.

    I wrote a mail to that pop account. Then I kept creating replies. Sometimes they showed up as drafts (often after 30 seconds when they also showed in the threaded view of the pop accounts mail inbox). Sometimes they wouldn't show in the drafts folder in which case I closed the draft and saved it, which resulted in the draft showing in the draft folder as expected.

    Next step: send the reply off, and see what happens to the draft. In at least one occasion I ran into this problem and the remaining draft even survived a restart of mail. So it looked to have decided to stay in the drafts folder indefinitely.

    I kept repeating that process over and over and in all the other attempts, things worked as expected. The draft was sent and disappeared from the drafts folder.

    Right now I'm very undecided if this is at all related to GPGMail.

    If you are able to come up with a more reliable pattern to reproduce this issue, it would be great. Also please experiment with GPGMail and without GPGMail.

    To temporarily disable GPGMail:

    • shut down
    • open finder
    • navigate to /Library/Mail/Bundles or ~/Library/Mail/Bundles and copy GPGMail.mailbundle to your desktop
    • now delete GPGMail.mailbundle from the original folder

    Restart mail and check in > Preferences if you still see GPGMail. It should be gone.

    So far from my side, maybe we can come up with more details to trigger the problem.


  2. 2 Posted by Valentin Garbe on 29 Mar, 2015 07:40 AM

    Valentin Garbe's Avatar

    Hi Steve,

    Thanks for your answer!
    After I deinstalled GPGTools, the problem with drafts was gone, so I’m sure its connected somehow to the GPGTools, certainly to the mailbundle.

    I installed the Beta 6.
    On the one hand, there is positive feedback: GPGMail works fine now for messages to which OpenPGP is applied. Thank you.

    But on the other hand, the problem still exists for messages to which S/MIME or no encryption is applied. There, drafts from replying a message are still saved in the conversation feed and are not deleted after the mail was send. And again, every saved state of the draft is saved as a single mail in the feed! In addition, after sending the mail, its not deleted from the mailbox „Drafts“.

    You should be able to easily reproduce this issue by just replying to a messages with OpenPGP off (may be you use a different mail account to which no PGP key is connected or you use a S/MIME account.
    I’m using Mails full screen mode on Mavericks.

    To make sure, I’m running the following system:
    - GPGMail 2.5b6 (917b), "Encrypt drafts" is activated - POP3 - Mail Version 7.3 (1878.6) on Mavericks 10.9.5

    I’m still waiting for an update and until then I have to deactivate the mailbundle.
    Best regards!

    Am 27.03.2015 um 19:32 schrieb Steve [email blocked]:

  3. Support Staff 3 Posted by Steve on 29 Mar, 2015 04:23 PM

    Steve's Avatar

    Hey Valentin,

    after a lot of more testing we have identified the issue to be affecting 10.9 and 10.10. On 10.10 the situation isn't as bad as on 10.9 since on 10.10 only one mail is displayed in threaded view.

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll receive a notification. Feel free to open a new discussions should you run into further problems or need assistance.

    Maybe you can consider an update to 10.10, where the problem is not as bad or switch to IMAP as a workaround.

    We'll report back as soon as we have news regarding this issue.


  4. Steve closed this discussion on 03 Jun, 2015 02:15 PM.

  5. Support Staff 4 Posted by Steve on 07 Mar, 2018 01:06 PM

    Steve's Avatar

    The bug where created multiple drafts has been fixed by Apple in macOS 10.13. If you are still affected by this issue, consider updating to macOS 10.13 High Sierra.

  6. Steve closed this discussion on 07 Mar, 2018 01:06 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac