GPG Suite update failed and now nothing works (solved: OS X's installer framework had problems on specific computer, reinstall OSX solved the issue)

undapa's Avatar


20 Mar, 2015 10:25 AM

it couldn't find a file when i tried to open GPG Keychain so I uninstalled and tried to reinstall and got this message.. which is incomplete

  1. 1 Posted by Thomas_U on 20 Mar, 2015 10:40 AM

    Thomas_U's Avatar

    Try again but run the uninstaller first. You won´t loose any data or settings but will get a clean install of all the suite´s elements.

  2. 2 Posted by undapa on 20 Mar, 2015 10:48 AM

    undapa's Avatar

    thanks mate, tried that and the uninstall was good to go, but the install had the same installation failure message.

  3. 3 Posted by undapa on 20 Mar, 2015 10:54 AM

    undapa's Avatar
  4. 4 Posted by undapa on 20 Mar, 2015 11:22 AM

    undapa's Avatar

    Just tried to reinstall keychain from a backup and got the error message "Libmacgpg was not found. Libmacgpg was not found on your system. Please reinstall GPG Suite from

    I feel like its groundhog day.

  5. 5 Posted by Thomas_U on 20 Mar, 2015 11:45 AM

    Thomas_U's Avatar

    At this point it help to know the OSX- and Mail-versions you use.

    What I would do if this was happening to me under 10.10.2 and Mail 8.2 (2070.6):

    Use Onyx (free) or Cocktail (commercial) to repair permissions and clean all caches.

    After that run the uninstall/install-routine with the latest nightly (beta6).

    Maybe someone from support-staff shows up here later in the day, I am just an experienced user. Good luck!

  6. Support Staff 6 Posted by Luke Le on 20 Mar, 2015 11:54 AM

    Luke Le's Avatar

    Hi Kane,

    very sorry to hear you're experiencing problems.
    Could you please follow the steps described in the link below to create an installer log for us? That will help us to figure out what's wrong.


    @Thomas_U: thank you for helping out :)

  7. 7 Posted by undapa on 20 Mar, 2015 12:51 PM

    undapa's Avatar

    thanks Thomas, did a verify dick permissions and a repair followed by an uninstall and install to no avail.

    Ive attached the installer log Luke.


  8. Support Staff 8 Posted by Luke Le on 20 Mar, 2015 12:56 PM

    Luke Le's Avatar

    Hi Kane,

    the install log looks rather bad. It seems like the OS X's installer framework has some problems on your computer. The only thread I could find on the problem is proposing to re-install your OS.

    Could you try to install any other software which uses pkg files.
    I don't think it's related to our installer, but if other pkgs work, it might be.

  9. 9 Posted by undapa on 20 Mar, 2015 09:58 PM

    undapa's Avatar

    reinstalled OS x yosemite and i was able to install gpgsuite

    thanks Luke!

  10. Support Staff 10 Posted by Steve on 21 Mar, 2015 03:45 PM

    Steve's Avatar

    Hi Kane,

    thanks a lot for the update. Sorry you had to go through the rather annoying procedure of reinstalling OS X. But at least it indeed solved this issue and we know this was not specifically related to the GPG Suite installer.

    Glad, this is solved for you. I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  11. Steve closed this discussion on 21 Mar, 2015 03:45 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac