Unable to send encrypted email to myself

wingman's Avatar


09 Nov, 2014 10:28 AM


i am using the beta version with 10.10 OS X. I have just generated a 4096 RSA key and tried to email myself. At that point I get the attached error. I have no problems just signing and sending. The error appears only after trying to encrypt (whilst trying to send the email)

Can't send any encrypted email to anyone at the moment using the beta GPG version. no errors on the console.app apart from the one attached on my previous post (exact same error)

  1. 1 Posted by wingman on 09 Nov, 2014 10:53 PM

    wingman's Avatar

    same issue when trying to send email to another user (error attached). Not sure what "EA1589E58EED787A" is as this is not the public key for the user I am trying to send to

    Update: It seems it was related to 'hidden-encrypt-to' settings within the ~/.gnupg/gpg.conf file
    I have removed this and everything seems to work fine (inc. sending emails to myself)

  2. Support Staff 2 Posted by Luke Le on 10 Nov, 2014 08:25 PM

    Luke Le's Avatar

    Hi wingman,

    could you post what you added your gpg.conf?
    It would be interesting to see if we could something about that failing.


  3. 3 Posted by wingman on 10 Nov, 2014 10:30 PM

    wingman's Avatar

    Hi Luke

    I have attached the relevant config. The only line removed was : hidden-encrypt-to with my key which was used so that I could see the encrypted items stored on my "send" folder


  4. Support Staff 4 Posted by Luke Le on 14 Nov, 2014 12:48 AM

    Luke Le's Avatar

    Ah great, thanks!
    We'll have a look into that.

    Closing this discussion in the meantime.

    Have a nice day :)

  5. Luke Le closed this discussion on 14 Nov, 2014 12:48 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac