cannot decrypt a file sent by email

Carl Ering's Avatar

Carl Ering

26 Feb, 2015 07:44 AM

Build: 761b Version: 1.5b5

I got an encrypted GPG annex in an email from a client on the MAC /Yosemite
There was an annoying alert about entering passphrase. Annoying because I could not click it away for later, I always reappeard.
I did not see the annex and thought I need to enter my passphrase, what I did, and got the the alert away.

Then I tried to open the annex later and it failed decrypting with error 0.

Exoected behavior:
The password does not work (obviously, it was trying mine, not the foreign) and it aks for a new password,
instead of just failing.

Cheers

  1. Support Staff 1 Posted by Steve on 26 Feb, 2015 04:49 PM

    Steve's Avatar

    Hi Carl,

    first you should be able to cancle pinentry requests. Please open Mail.app > Preferences > GPGMail and disable the "List Preview" if that option is active. That should prevent pinentry asking for your passphrase for all mails in view.

    If you enter a wrong passphrase, pinentry will ask again since you obviously want to try to decrypt something and maybe just entered a typo. This process repeats two times. After that, pinentry should be quiet and not ask again, at least not for that specific mail.

    The email you received, is that encrypted or signed or signed and encrypted or nothing of the above and it just contains an encrypted attachment?

    All the best,
    steve

  2. Support Staff 2 Posted by Steve on 02 Jun, 2015 12:16 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  3. Steve closed this discussion on 02 Jun, 2015 12:16 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac