Unable to send a signed message or even re-install due to "package tampered with"

Alexej Kubarev's Avatar

Alexej Kubarev

25 Feb, 2015 04:45 PM

I was trying to send a message and sign it (not encrypt) as i always did but suddenly GPG Mail gave me a warning about being tampered with (?). Restarting Mail.app keeps it disabled with yellow indicator "Please check your installation or configuration".

So decided to re-download the package (Beta 5) and reinstall but getting the error about the "The package may have been corrupted or tampered with. Get a new copy of the package and try again." When I try to run the installer. Download 4 times from different locations even..

What's going on all of a sudden?

  1. Support Staff 1 Posted by Steve on 25 Feb, 2015 07:14 PM

    Steve's Avatar

    Hi Alexej,

    from which locations are you downloading the installer?

    Can you please copy all version info as described here into this discussion.

    Also can you please download our public key from https://gpgtools.org/
    Direktlink: https://gpgtools.org/GPGTools%2000D026C4.asc and import it to GPG Keychain.

    Does the issue then persist?

    All the best,

  2. 2 Posted by Alexej Kubarev on 26 Feb, 2015 01:24 PM

    Alexej Kubarev's Avatar

    Hi Steve,
    By multiple locations I ment (from home, at work, etc) to ensure this was not something dodgy with the network itself (I know, pretty stupid thing but you never know).

    When importing the key i did get a notification that it has not been changed. What is confusing me - I was unable to open any of the GPG Tools, including keychain at the time of creating the ticket. I do not thing anything changed on my side either.

    The version in question was 2.5b5 just like the one I re-downloaded and successfully reinstalled now (I was unable to do it or before).

  3. Support Staff 3 Posted by Steve on 26 Feb, 2015 04:27 PM

    Steve's Avatar

    Hi Alexej,

    so you now downloaded and installed GPG Suite b5?

    Are things now working as expected or are you still seeing issues?

  4. 4 Posted by Alexej Kubarev on 27 Feb, 2015 09:02 AM

    Alexej Kubarev's Avatar

    Hi Steve,
    This is the exactly same version that I had when issue appeared and the same file that was failing to be installed. But now it worked without me doing anything., This is strange but I wonder if there was a hickup in something that was used to verify a digital signature?

    To be clear: I was running Beta 5 since it was released in early Feb, then suddenly this issue appeared so I tried to downlaod a new copy (even though it's the same version) and re-install, but hit the signature issue even there. After creating this ticket, the next day I tried to import the key and it said that it's the same as I already have (I could've sworn I had problem opening a GPG Keychain as well). After this - I tried to install the already download version again (Beta 5 installer that was complaining the day before) and it all went through and seems to be working now.

  5. Support Staff 5 Posted by Steve on 27 Feb, 2015 12:50 PM

    Steve's Avatar

    This sounds pretty odd indeed. Since things now seem to be running smoothly I'll close this discussion, but please make sure to re-open and do let us know if more problems arise.

    All the best,

  6. Steve closed this discussion on 27 Feb, 2015 12:50 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac