DSA-Elgamal keys won't encrypt or decrypt in Beta-4

Clarence's Avatar


27 Jan, 2015 05:16 PM

I am unable to encrypt or decrypt using DSA-Elgamal under Beta 4.

The PinEntry error I'm getting is "bad password".

My passwords and keys all work under GPG Suite - 2013.10.22

All keys are 3,072 in length and were created from GPG Suite - 2013.10.22, GPG Keychain Access Version 1.1.3 (601)

OSX 10.8.5
Thunderbird 31.4.0
Enigmail 1.7.2

Thank you in advance..

  1. Support Staff 1 Posted by Steve on 31 Jan, 2015 10:42 PM

    Steve's Avatar

    Hi Clarence,

    could you please download and install our latest nightly build and see if the problem persists. That page also has sig and SHA1 to verify the download.

    I do not have any DSA Elgamal Keys here so I created a test key using the latest nightly GPG Suite and encryption, signing, decryption and verification all worked fine.

    If the problems persit using the latest nightly GPG Suite, could you create a new DSA Elgamal key and see if the issues persist?

    How many keys are no longer operational now? Did you ever store your passphrases in the OS X keychain?

    All the best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by Clarence on 01 Feb, 2015 05:06 PM

    Clarence's Avatar

    The issue seems to be with the length of my pass phrases not with the DAS keys themselves. My apologies for overlooking this in the first place.

    Will the finished version be capable of handing astronomically long pass phrases?

  3. 3 Posted by Clarence on 01 Feb, 2015 05:25 PM

    Clarence's Avatar

    It looks like out of 6 DSA keys only the key I use primarily was affected. And I don't store my passphrases in the OSX keychain.

    I had to create a new key, which wasn't a bad thing anyhow and everything seems to be back to normal.

    Thanks for your attention..


  4. 4 Posted by Clarence on 01 Feb, 2015 05:58 PM

    Clarence's Avatar

    I was able to create a new key but I'm still getting a pin entry error when trying to encrypt. emails with my new key. It appears that the nightly build of GPG Keychain will accept my new passphrase but pinentry will not.

    I'm copying and pasting the passphrase so I know it's entering correctly..

    From my observations it looks like it's a passphrase length issue with pinentry. I'll keep working away on this end to test this out further..

    My sincerest apologies for all the replies. I thought I had this one figured out.

  5. 5 Posted by Clarence on 01 Feb, 2015 06:10 PM

    Clarence's Avatar

    Ok I'm dumb.. I had forgotten to switch out my keys in enigmail..

    Problem solved

    I need more sleep..

    Sorry again for all the messages. I sure hope someone gets a good laugh out of this.. :-)

  6. Support Staff 6 Posted by Luke Le on 01 Feb, 2015 09:21 PM

    Luke Le's Avatar

    Hi Clarence,

    nevermind :) Very happy you found the solution yourself.

    Closing this discussion. Have a nice day!

  7. Luke Le closed this discussion on 01 Feb, 2015 09:21 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac