Signature not valid

Frank's Avatar


02 Jan, 2015 10:11 PM

GPG Mail Version 2.5b4 Build: 802b
OSX 10.10.1

i sent a mail yesterday evening to my father and today Apple Mail claims that the signature is not valid. I checked the email while i logged in to my fathers email account and the text is the same

What did you expect instead

signature should be valid

none other plugins in Apple Mail

  1. 1 Posted by Frank on 02 Jan, 2015 10:24 PM

    Frank's Avatar

    ok, found out something. maybe it helps.

    i sent an email to another email account of me and attached a 4.5 mb pdf. in the mail-outbox the signature is marked as invalid immediately, in the mail-inbox the signature is ok. see also screenshots

  2. Support Staff 2 Posted by Steve on 12 Jan, 2015 10:03 PM

    Steve's Avatar

    HI Frank,

    I ran into this issue a few weeks ago. We had a closer look and it seems that mail somehow manages to stored mails incompletely (IMAP seems to mess up). Maybe wait a while and revisit your sent folder again later. Does the issue persist? If the mail is loaded incompletely, the signature (correctly) then would be invalid.

    To investigate this further:

    Can you log into your webmail, and decrypt the mail in question and then see if the signature verifies correctly.

    Also could you resend the attachment in question and see if the new mail also has an invalid signature in the outbox?

    All the best,

  3. 3 Posted by Frank Ofner on 12 Jan, 2015 10:58 PM

    Frank Ofner's Avatar

    hello Steve

    indeed, it’s an tricky issue.
    while i forwarded the email to myself and checked the email in the inbox, the signature of the original email in the outbox is unvalid

    when i look at the same original mail in the outbox, the signature is valid

    when i download the signature.asc and check it with gpstools, the tool says, the signature is not valid

    resending an email turnes the signature to valid

    hope it helps

  4. Support Staff 4 Posted by Steve on 14 Jan, 2015 04:19 PM

    Steve's Avatar

    Are there any exchange servers involved in your mail setup?

  5. 5 Posted by Frank Ofner on 14 Jan, 2015 07:31 PM

    Frank Ofner's Avatar

    hello Steve

    no, no exchange servers. but i recognised something. see the screenshot of apple mail. the attachment is located between text and regards. in the webmail the attachment is seperate and the space between the text and regards has gone. maybe this could be the problem.


    so i made a quick check with a mail and the attachment at the end of the mail, and the signature works :-)


  6. Support Staff 6 Posted by Steve on 04 Feb, 2015 10:28 PM

    Steve's Avatar

    Hi Frank,

    so from what I see, as long as you display the mail in the signature verifies as expected. Only in webmail you get an invalid signature. And if the webmailer indeed mangles the mail in a way you desscribe (change image position or such) the mail is altered. The fact that then you receive an invalid signature is rather reassuring because the mail has indeed been tampered with. So I'd say this is a case of "works as expected".

    Which webmail is being used here, if I may ask?

    All the best,

  7. 7 Posted by Frank Ofner on 05 Feb, 2015 10:29 AM

    Frank Ofner's Avatar

    Hi Steve

    sorry, the other way round :-(

    the email pgp-signature is marked as invalid in This happens independt of the mail account (and webmail) i use. the one is the A1 mail account (Austrian Telekom) and the other one is the mail account of my personal provider.

    i think the problem is, that „integrates“ a pdf, jpg etc. in the mail and text while windows mail programs and also webmail handle these pdf, jpg etc as attachements. So an mail sent by is always „reconfigurated“ when an attachment is placed somewhere in the text. There is no problem with the pgp-signature when the attachments are placed after the complimentary close.

  8. Support Staff 8 Posted by Steve on 05 Feb, 2015 11:39 PM

    Steve's Avatar

    Frank, could you create such a mail which results in an invalid signature and send it to teamATgpgtoolsDOTorg please.

  9. 9 Posted by Frank Ofner on 06 Feb, 2015 11:03 AM

    Frank Ofner's Avatar

    Part1 Outbox Mail with Attachment after salutation

  10. 10 Posted by Frank Ofner on 06 Feb, 2015 11:08 AM

    Frank Ofner's Avatar

    Part2 Inbox Mail with Attachment after salutation

  11. 11 Posted by Frank Ofner on 06 Feb, 2015 12:04 PM

    Frank Ofner's Avatar

    Part3 Outbox - Mail with attachment before salutation

  12. 12 Posted by Frank Ofner on 06 Feb, 2015 12:08 PM

    Frank Ofner's Avatar

    Part4 Inbox Mail with attachment before salutation

  13. 13 Posted by Frank Ofner on 06 Feb, 2015 12:12 PM

    Frank Ofner's Avatar

    Part3 Outbox - Mail with attachment before salutation

  14. 14 Posted by Frank Ofner on 06 Feb, 2015 12:15 PM

    Frank Ofner's Avatar

    ! something strange happened ! today the signature worked fine but when you have a closer look at the email and the screenshot, you’ll see that the part of the Email after the attachment has gone. Inclusive the salutation. Both in AppleMail Outbox and in the Webmail Outbox and Webmail Inbox. The mail is displayed right only in AppleMail Inbox.

    Frank :confused:

  15. Support Staff 15 Posted by Steve on 06 Feb, 2015 01:08 PM

    Steve's Avatar

    Frank could you please hop on our live chat:

  16. Support Staff 16 Posted by Steve on 06 Feb, 2015 01:19 PM

    Steve's Avatar

    Frank's current setup:

    Mac OS X: 10.10.1 (14B25)
    MacGPG2: 2.0.26b2, 750b
    GPG Keychain: 1.2b3, 980b
    GPGServices: 1.10b2, 730b
    GPGPreferences: 1.5b2, 730b
    GPGMail: 2.5b4, 802b

  17. Support Staff 17 Posted by Steve on 06 Feb, 2015 01:39 PM

    Steve's Avatar

    Frank updated to the latest nightly and things are now working as expected.

    If this re-appears, please re-open and do let us know.

    Closing for now.

  18. Steve closed this discussion on 06 Feb, 2015 01:39 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac