switch between multiple private keys / select private key - for same identity/ies when writing mail

Niels Dettenbach's Avatar

Niels Dettenbach

24 Dec, 2014 01:13 PM

GPGmail, GPG Keychain or/and GPGServices latest/current available beta

After importing a newer private key for the same IDs i can't switch to the new key within mails anymore. I'm not shure if this is related to the session (will try this next as possible) - i did not clicked (checkbox) to save passphrase in key manager, but i did not get any new requests when sending further mails with sign and crypt (so i assume my credentials are in gig agent or similiar).

Where can i switch the used key during a session? I need the old key for that set of IDs because some peoples still write me with that (outdated) key.

What did you expect instead

An option under Mail->Preferences->GPG or on the GPG part on the mail window or the email user identity or in the GPG Keychain tool allowing me to set my default sign/crypt key.

Describe steps leading to the problem.

  1. write an email with GPG sign/crypt (with default/current key)
  2. import (or possibly create) a new key with same IDs as the former mainly used key
  3. try to change the key when write new emails

If your problem concerns GPGMail, are you using any other plugins? No.

Thanx guys,

Niels Dettenbach
Syndicat IT & Internet

  1. Support Staff 1 Posted by Steve on 25 Dec, 2014 07:56 PM

    Steve's Avatar

    Hi Niels,

    this area could indeed use some tweaking. Could you try and see, if the situation improves and the new key is used by default if you set it as "Default Key" in GPGPreferences > Settings.

    That way it should be used to sign new mails from that Mail Account and the old key should still be around to decrypt any incoming mails to that old key or for existing mails encrypted with the pub key of your old key.

    Let me know if that worked.

    All the best,

  2. 2 Posted by Niels Dettenbac... on 06 Jan, 2015 08:04 PM

    Niels Dettenbach (Syndicat.com)'s Avatar

    No content.

  3. 3 Posted by penny on 05 Feb, 2015 10:40 AM

    penny's Avatar

    I have the same issue and the fix suggested above didn't work for me - I restarted Mail and tried again with a new message (ie, didn't retry with the same draft, in case the key was cached) and it still tried to sign with the old key.

    Although in my case this is the first time using Mail at all (I am testing switching over from Thunderbird) and I always had those two keys in my keychain.

  4. Support Staff 4 Posted by Steve on 05 Feb, 2015 11:54 PM

    Steve's Avatar

    Hi Niels,

    your reply did not make it here. Please visit this discussion with your webbrowser and reply from there.

    @Penny: So you do have two keys for the same mail address. Are you using both or is one of the keys revoked? Are you in the midst of transitioning from one key to another?

    If two keys exist for the same mail address, you will find a selection (showing the Short ID) when you expand the "From" selection while composing a new mail.

    Please let me know if that works for you.

    All the best,

  5. 5 Posted by penny on 06 Feb, 2015 10:14 AM

    penny's Avatar

    Hi Steve, thanks for replying! Yes, two keys for the same email address. I haven't revoked the old one yet. Anyway I don't get any key selection in the From field of a new email (see attached screenshot), yet in the gpg Preferences system preferences pane, it autodetects 4 keys I control and offers all of them as options for the default. (See second screenshot).

    Also sorry if I hijacked a thread about a different issue! Oops :)


  6. Support Staff 6 Posted by Steve on 06 Feb, 2015 10:28 AM

    Steve's Avatar

    Penny, please open GPG Keychain and double click your sec/pub key. Then see if the key is still valid and post the key capabilities here for each key.

    Next check if all UserIDs are still valid. And at last check if the subkey is still valid.

  7. 7 Posted by penny on 06 Feb, 2015 10:33 AM

    penny's Avatar

    Huh. Both keys are the same...

    Validity: unknown. Capabilities esc. All User IDs have validity unknown and the subkey also has validity unknown.

  8. Support Staff 8 Posted by Steve on 06 Feb, 2015 10:36 AM

    Steve's Avatar

    Sorry I meant if any of those components are expired. Could you hop on our live chat: https://www.hipchat.com/gi8zHW4K3

  9. Support Staff 9 Posted by Steve on 06 Feb, 2015 01:06 PM

    Steve's Avatar

    Resolved via LiveSupport. Penny thanks for helping us debug this issue.

  10. Steve closed this discussion on 28 May, 2015 06:41 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac