After upgrading I can not decrypt due to "Passphrase too long" error

Snooby's Avatar


07 Dec, 2017 04:36 AM

I've updated my installation with the latest betas and am unable to decrypt due to a persistent error of "Passphrase too long". Should I downgrade my installation?

  1. Support Staff 1 Posted by Luke Le on 08 Dec, 2017 06:42 PM

    Luke Le's Avatar

    Hi Snooby,

    would you mind telling us what length your passphrase has?
    It is true, that we have decreased the maximum passphrase length to adjust our settings to the original GnuPG settings, which might cause an error in your case.

    A downgrade to 2017.1 should probably help.

  2. Support Staff 2 Posted by Steve on 09 Dec, 2017 11:38 PM

    Steve's Avatar

    Could you please send a debug log from your affected machine: Open System Preferences > GPG Suite > Send Report. Check the box to "attach debug log". Since you already described your issue in this discussion, you don't need to add a lot of detail, but please do add the link to your existing discussion, so I can then merge your debug info with this existing discussion.

    All the best,

  3. Support Staff 3 Posted by Steve on 26 Mar, 2018 02:36 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  4. Steve closed this discussion on 26 Mar, 2018 02:36 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac