Issues with encrypted drafts when changing account with POP accounts (was: Bug: Encrypted drafts)

Oliver's Avatar


27 Nov, 2014 07:43 AM

GPGMail 2.5b2 Build 792b

  • Start to write a uncrypted, unsigned new mail.
  • Click into your drafts folder
  • Select written mail -> You have to type in your password, because it looks like, the mail is encrypted, but is not!

Tested with OsX 10.10.1, Mail 8.1, IMAP-account, drafts saved locally

Please describe what you did expect instead

No password, mail not encrypted

  1. 1 Posted by Jason on 02 Dec, 2014 05:58 PM

    Jason's Avatar

    Still an issue in 2.5b3 build 797b

  2. Support Staff 2 Posted by Luke Le on 02 Dec, 2014 06:00 PM

    Luke Le's Avatar

    H Oliver,

    for the drafts to be encrypted, you have to enable the option "Encrypt drafts" in -> Preferences -> GPGMail
    Could you please check if that option is in fact enabled?
    To verify independently of GPGMail if a message is in fact encrypted, you can do that by selecting your message, and the opening the menu View -> Email -> Raw message

    If you find the plain text in there it is in fact not encrypted.

    Please let us know what you find.

  3. 3 Posted by Oliver on 05 Dec, 2014 10:56 AM

    Oliver's Avatar

    Hi Le,

    thanks for checking my ticket.

    This morning I did the update to beta 3. Then I saw, that there is a checkbox in Mails configuration „encrypt drafts“. After updating the checkbox was not checked anymore, but I remember, that it was checked before I did the update.

    Now it seems to work properly:

    • Checkbox is on: every draft is saved encrypted
    • Checkbos is off: drafts are never saved encrypted

    I may not decide, if this is the right behavior. If you ask me, you should remove the checkbox „encrypt drafts“ and do it automatically depending on the selected option during writing a new mail. If the user selects, that the mail has to be signed and encrypted, the draft should be saved with encryption otherwise without.

    Update: As I saw on an older discussion (, you find it easier, to encrypt all drafts, if checkbox is checked. So this ticket can be closed.

  4. 4 Posted by evergreen on 05 Dec, 2014 07:08 PM

    evergreen's Avatar

    GPGMail - Beta
    Version 2.5b3 Build 797b
    Tested with OsX 10.10.1, Mail 8.1 (1993), POP-account, drafts UNsaved LOST

    There are various bugs relating to editing/saving drafts.

    When the "Encrypt drafts" item is CHECKED, drafts may fail to save COMPLETELY.
    Which is annoying if you lost a long message, closed after you thought Save was working.

    Turning that OFF, the message sidebar still fails to update appropriately, and changes may still not be saved.

    I'm uninstalling until some of these issues are resolved.


  5. Support Staff 5 Posted by Luke Le on 05 Dec, 2014 07:11 PM

    Luke Le's Avatar

    Hi RC,

    we're very sorry you're running into problems.
    We think this might be related to the legacy inline pgp option being enabled.
    Could you please run the following command in Terminal and post the output:

    defaults read org.gpgtools.gpgmail UseOpenPGPInlineToSend


  6. 6 Posted by evergreen on 05 Dec, 2014 07:28 PM

    evergreen's Avatar

    BTW, another problem relates to changing between email accounts while editing a message and saving drafts.
    If only one account is protected by GPGTools, but you have multiple POP accounts:
    saving a draft created for the protected account, and then switching
    to save the draft with another account, is a problem.
    The saved draft becomes unusable by either account.
    A fix is to copy/paste into a new draft, and make sure the account is right (unprotected by GPGTools) before saving.
    But, not really a fix.

  7. 7 Posted by evergreen on 05 Dec, 2014 07:29 PM

    evergreen's Avatar

    $ defaults read org.gpgtools.gpgmail UseOpenPGPInlineToSend 2014-12-05 11:28:19.138 defaults[11022:832799]
    The domain/default pair of (/Users/xxx/Library/Preferences/org.gpgtools.gpgmail, UseOpenPGPInlineToSend) does not exist

  8. Support Staff 8 Posted by Luke Le on 05 Dec, 2014 07:42 PM

    Luke Le's Avatar

    Hmm... this is very strange indeed.
    Could you please check if you're seeing any error message in
    It's really strange this is happening to you.

  9. 9 Posted by evergreen on 05 Dec, 2014 07:49 PM

    evergreen's Avatar

    Nothing relevant in Console that I can see.
    BTW, will uninstalling current beta delete my GPG keychain?
    I'd rather avoid that, so can try next beta ;-)

  10. Support Staff 10 Posted by Luke Le on 05 Dec, 2014 08:07 PM

    Luke Le's Avatar

    I will setup a Pop account and try to re-create this problem.
    Do you have an IMAP account where this is happening as well, btw?

  11. 11 Posted by evergreen on 05 Dec, 2014 08:37 PM

    evergreen's Avatar

    Nope no IMAP here. I avoid IMAP because it always seemed buggy compared to POP. But maybe Apple has made them equally buggy these days!

  12. Support Staff 12 Posted by Steve on 10 Jan, 2015 06:27 PM

    Steve's Avatar

    Hi Evergreen,

    1. GPG Suite Beta 4 is available via our homepage. Please update and let us know if the issues persist.

    2. Would you mind to change one of your accounts to IMAP and see if the issues persist using that protocal? IMAP works pretty reliable for me here and I do have quite a few accounts setup in Maybe it has improved?

    All the best,

  13. Support Staff 13 Posted by Steve on 26 Mar, 2015 03:21 PM

    Steve's Avatar

    @evergreen: if any issues are persisting using GPG Suite beta 6, please create a separate discussion. Otherwise this will be very confusing.

    @Oliver: What's the status for you? Are your issues persisting with GPG Suite b6?

  14. Support Staff 14 Posted by Steve on 26 Mar, 2015 03:22 PM

    Steve's Avatar

    Ah ok, actually Oliver was already solved.

    Closing this discussion. Evergreen if anything is persisting for you, let's start a new discussion and with a clean slate.

  15. Steve closed this discussion on 26 Mar, 2015 03:22 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac