GPGMail: S/MIME E-Mail encryption disabled

Patrick Stoeckle's Avatar

Patrick Stoeckle

01 Sep, 2017 11:53 AM

If GPGMail is installed, the S/MIME E-Mail encryption does not work. I can send an S/MIME signed e-mail, but the S/MIME encryption is disabled although I am answering to an S/MIME signed E-Mail or writing to an address with an trustworthy certificate.

Expected
If GPGMail is installed, the S/MIME E-Mail encryption should work

macOS           10.12.6     16G29
GPG Suite       2017.1b3    1812    (d43863c)
GPGMail         2.7b3       1215    (d0b5fa0)
GPG Keychain    1.3.3b2     1271    (028a4a2)
GPGServices     1.11        916     (872e77d)
MacGPG2         2.0.30-1b2  887-    (4912d26)
GPGPreferences  2.0.2b3     927     (641418e)
Libmacgpg       0.7         782     (536bf51)
pinentry        0.9.7       4       (b75069d)
  1. Support Staff 1 Posted by Steve on 06 Sep, 2017 03:43 PM

    Steve's Avatar

    Hi Patrick,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you try to export, delete and re-import the S/MIME cert and see if that improves the situation?

    Also you might want to update to the latest nightly build:
    https://releases.gpgtools.org/nightlies/

    Are you then still seeing the same problem?

    If yes, could you please temporarily disable GPGMail:

    • shut down mail.app
    • open finder
    • navigate to /Library/Mail/Bundles or ~/Library/Mail/Bundles and copy GPGMail.mailbundle to your desktop
    • now delete GPGMail.mailbundle from the original folder

    Restart mail and check in Mail.app > Preferences if you still see GPGMail. It should be gone.

    To re-enable mail, close Mail.app and move the bundle file back to the Bundles folder.

    Let me know the test results and how this went.

    All the best,
    steve

  2. 2 Posted by Patrick Stöckle on 07 Sep, 2017 03:55 PM

    Patrick Stöckle's Avatar

    Hi Steve,
    the export, delete and reimport stuff solved the problem. Thank you for you help!
    Kind regards,
    Patrick

  3. Support Staff 3 Posted by Steve on 07 Sep, 2017 05:09 PM

    Steve's Avatar

    Perfect. Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  4. Steve closed this discussion on 07 Sep, 2017 05:09 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac