10.10.1 Can't generate key pair & can't import keys from keyserver

Jack Bunce's Avatar

Jack Bunce

20 Nov, 2014 01:07 AM

GPG Keychain


Version 1.2b1 (940b)

I tried to generate a key pair but it never seemed to complete.

I had previously, on another system I think, generated a key pair and uploaded it to a keyserver. I did a search for that and found it and attempted to import the public key. It told me it had imported but it never showed up in the window. Then I generated a new key pair on my Android phone using APG and uploaded that public key. Once again I did a search and this time both public keys showed up and I attempted once again to import them from the server. Once again, it told me they were being imported and the window open up but contained no keys!

My system is a mid 2007 iMac with 4 GB running 10.10.1

  1. 1 Posted by Jack Bunce on 20 Nov, 2014 01:44 AM

    Jack Bunce's Avatar

    Now I am getting an error on the key gen "Code=0)" "Error Text gpg: problem with the agent: End of file"

  2. 2 Posted by Jack Bunce on 20 Nov, 2014 02:16 AM

    Jack Bunce's Avatar

    Now I just downloaded your key and tried to import it and I get the message that it can't be imported and that may be because it wasn't signed!

  3. Support Staff 3 Posted by Steve on 21 Dec, 2014 01:11 PM

    Steve's Avatar

    Hi Jack,

    could you please download and install our latest nightly build and see if the problem persists.

    You can find sig and SHA1 on the GPGTools Nightlies page.

    All the best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  4. 4 Posted by Jack Bunce on 21 Dec, 2014 04:04 PM

    Jack Bunce's Avatar

    Thanks for the reply, Steve.

    I found this tip in another thread prior to your reply and downloaded and
    installed a nightly build a few days back and it works. Subsequently I
    think I did another uninstall and update and it seems to still be working.

    Still running 10.10.1 on a 20 inch mid-2007 iMac with Apple Mail 8.1(1993)
    and GPG Keychain V 1.2b2(954b) <=== not certain if this is a nightly build
    or not :))

  5. Support Staff 5 Posted by Steve on 21 Dec, 2014 04:10 PM

    Steve's Avatar

    Hi Jack,

    glad, this is solved for you. I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    The 954b build info indicates a beta build. The latest nightly build is 970n. But if things are working now, there's no real need to switch to the nightly channel.

    All the best,

    Best, steve

  6. Steve closed this discussion on 21 Dec, 2014 04:10 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac