GPGMail: GPGMail stopped signing messages and decrypting messages.

Brion Emde's Avatar

Brion Emde

07 Aug, 2017 10:03 PM

I first noticed that it was complaining that it could not decrypt messages from Facebook. I thought there was something wrong with the key from Facebook, so re-imported it. Then I realized that GPGMail hasn’t been asking me for my password when I send messages either and I checked and outgoing messages are not being signed anymore. That worked for a few weeks and has just stopped working for some reason.

I’d expect it to tell me that it is no longer signing messages and that there was a problem in the process. I still don’t know why this stopped working.

macOS           10.11.6     15G1611
GPG Suite       2017.1b3    1812    (d43863c)
GPGMail         2.6.3b1     1181    (9c4c1f4)
GPG Keychain    1.3.3b2     1271    (028a4a2)
GPGServices     1.11        916     (872e77d)
MacGPG2         2.0.30-1b2  887-    (4912d26)
GPGPreferences  2.0.2b3     927     (641418e)
Libmacgpg       0.7         782     (536bf51)
pinentry        0.9.7       4       (b75069d)
  1. 1 Posted by Brion Emde on 07 Aug, 2017 11:37 PM

    Brion Emde's Avatar

    I got to the root of the problem on my side. Somehow I degraded the public/private key that I'd generated, so it lost the private part of the key. Not sure how that happened. I'd been experimenting with the option to save the key to public key servers and maybe that's how it happened.

    So I revoked the old key and created a new one and told Facebook about the new key and everything is good again. I'll stop fiddling with it and perhaps figure out another way to share my public key.

    But the fact remains that GPGMail blithely stopped signing my messages, silently, without letting me know that something had gone wrong. When it was unable to sign a message, it should have notified me that somehow my key had gone bad.

  2. Support Staff 2 Posted by Steve on 09 Aug, 2017 12:14 PM

    Steve's Avatar

    Hi Brion,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Revoking the key with the lost sec key part was the right thing to do. Since you have not uploaded your public key, there's no reason to upload the now revoked key to the key servers.

    if you want you can upload the public key of the new sec/pub key you created. This KB-article explains how to find and share your public key.

    Let me know if that worked.

    When GPGMail cannot find a secret key for the mail account in question, it assumes rightly that the key has intentionally been removed. If OpenPGP is used to sign your messages you will see the star button in bright blue and the OpenPGP indicator at the top right in green. When no signing is happening both locations will be greyed out.

    Kind regards,

  3. Support Staff 3 Posted by Steve on 22 Oct, 2017 04:57 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  4. Steve closed this discussion on 22 Oct, 2017 04:57 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac