GPGMail on Yosemite does not send signature inline

Páll Hilmarsson's Avatar

Páll Hilmarsson

14 Nov, 2014 10:06 PM

Which of our tools is giving you problems? (GPGMail, GPGServices or GPG Keychain Access, …) GPGMail

Version 2.5b2 (build 792b)

After setting 'defaults write org.gpgtools.gpgmail UseOpenPGPInlineToSend -bool YES' emails are still sent with a signature.asc attached, and not with an inline signature.

Relevant headers:

--Apple-Mail=_F95C7725-BCEB-44DD-B78B-3BCA1DBFF56D Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
filename=signature.asc Content-Type: application/pgp-signature;
name=signature.asc Content-Description: Message signed with OpenPGP using GPGMail

The message is constructed with the OpenPGP option, since the S/MIME is not available (greyed out)

  1. 1 Posted by Florian on 30 Nov, 2014 03:58 PM

    Florian's Avatar

    I have the same issue here. I used the inline-option before upgrading to OS X 10.10 and it worked perfectly.
    SInce I upgraded I am using Version 2.5b2 (build 792b) and mails that I encrypt/sign don't get send. They are "stuck" in the outbox. If I set UseOpenPGPInlineToSend to NO everything works.

  2. 2 Posted by Jacob on 04 Dec, 2014 06:07 PM

    Jacob's Avatar

    Same issue here, please resolve this as soon as possible!

  3. Support Staff 3 Posted by Luke Le on 04 Dec, 2014 06:10 PM

    Luke Le's Avatar

    The build linked to in the following discussion should have a fix for this issue:
    http://support.gpgtools.org/discussions/beta-feedback/278-sent-mail...

    It would be great if you could test it and let us know if the problem persists.

  4. 4 Posted by Florian on 07 Dec, 2014 03:09 PM

    Florian's Avatar

    Thanks a lot, fixed it for me! Keep up the great work!

  5. 5 Posted by Páll Hilmarsson on 08 Dec, 2014 10:20 AM

    Páll Hilmarsson's Avatar

    This fixes it so that the signature is indeed sent inline, but it introduces another problem:

    Other attachments are stripped. Do you get that behaviour also, Florian?

  6. 6 Posted by Florian on 08 Dec, 2014 10:47 AM

    Florian's Avatar

    Just tried, same problem here. Attachements get deleted when clicking send.

  7. 7 Posted by Jakob Murko on 09 Dec, 2014 10:59 AM

    Jakob Murko's Avatar

    Same behaviour here. E-mail goes through, but any attachments are stripped
    from the e-mail. Afaik, you can't add the signature of the attachments into
    the inline signature, but I would like to send the attachments nonetheless.

  8. 8 Posted by Páll Hilmarsson on 31 Dec, 2014 06:01 PM

    Páll Hilmarsson's Avatar

    Seems that the latest beta has solved this (Version 2.5b4 Build: 802b)

  9. Support Staff 9 Posted by Steve on 31 Dec, 2014 06:10 PM

    Steve's Avatar

    Hi all,

    Paul thanks for your feedback. Glad this is now working.

    Jakub: Is PGP/MIME not working for you?
    Florian: we do not support Inline PGP attachments at the moment. We only support plaintext. Could you switch to PGP/MIME or is that no option for you?

    All the best,
    steve

  10. Steve closed this discussion on 02 May, 2015 06:43 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac