GPGMail: multiple drafts saved and sent

Robert Stark's Avatar

Robert Stark

18 May, 2017 03:22 PM

My drafts seem to be encrypted coded and sent to their intended recipient every 20 seconds or so, resulting in a thread that is 15-20 emails long, which concludes with the designed message. Am I missing something?

Expected
single mailing

macOS           10.12.4     16E195
GPG Suite       2017.1b3    1812    (d43863c)
GPGMail         2.7b3       1215    (d0b5fa0)
GPG Keychain    1.3.3b2     1271    (028a4a2)
GPGServices     1.11        916     (872e77d)
MacGPG2         2.0.30-1b2  887-    (4912d26)
GPGPreferences  2.0.2b3     927     (641418e)
Libmacgpg       0.7         782     (536bf51)
pinentry        0.9.7       4       (b75069d)
  1. Support Staff 1 Posted by Steve on 18 May, 2017 08:12 PM

    Steve's Avatar

    Hi Robert,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you send yourself a test mail and while working on the draft observe if the problem is reproducible. Also it would be interesting to learn, if indeed several messages are sent. Or could it be that "only" the drafts are piling up, while in the end a single message is sent?

    All the best,
    steve

  2. 2 Posted by Robert on 18 May, 2017 08:23 PM

    Robert 's Avatar

    Hi, Steve

    I think perhaps you helped me years ago get on this to start with: if so, thanks again!

    I'm pretty sure it is 'reproducible': Im using apple mail synced with a gmail account, so the record of the multiplicity lands there. Here's a couple of screengrabs that may illustrate.

    cheers
    Robert

  3. Support Staff 3 Posted by Steve on 18 May, 2017 08:32 PM

    Steve's Avatar

    Hey Robert,

    ha, that's great to hear. Yeah chances are that was me. Happy to hear, you did not give up on OpenPGP and secure communication and welcome.

    Should you be available, could you hop on our live chat here:
    https://www.hipchat.com/gyyOrLdWt

    We can't promise a solution, but we'd like to inspect this problem in more detail.

    All the best
    steve

  4. Support Staff 4 Posted by Steve on 18 May, 2017 10:41 PM

    Steve's Avatar

    While playing with this, a few things came to mind and should be worth trying:

    1. in gmail > webmail > settings go to POP/IMAP and let me know if IMAP is enabled or disabled for your account
    2. remove and re-add your gmail account in Mail.app and see if that changes anything
    3. you may disabled the feature to store drafts on the server. to do that, go to Mail.app > Preferences > Accounts > Mailbox behavior and for drafts select the bottom option "Local > Drafts"

    Good night,
    steve

  5. 5 Posted by Robert on 19 May, 2017 05:25 PM

    Robert 's Avatar

    Hi, Steve

    1. IMAP is enabled
    2. RE-added, with no noticable difference
    3. Done.

    Cheers
    Robert

  6. Support Staff 6 Posted by Steve on 21 Jun, 2017 03:17 PM

    Steve's Avatar

    The problem at hand is caused by a bug in Apples Mail.app. It already exists in Apples bug tracking system and is bug #7053869. We first reported this problem with multiple drafts to Apple back in 2013 as bug #15368837. That bug was set to dupe of #7053869, so the issue must have been know earlier.

    Please use their feedback form to inform Apple about this problem and ask them kindly to consider investing the time to fix this long-standing Mail.app bug. It may help to add the bug number, so they know which issue you are referring to.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • 2017-05-18_15-22_DebugInfo.gpg 15.7 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac