GPGMail: Innline/PGP attachments are not being decrypted

Daniel Zimmermann's Avatar

Daniel Zimmermann

01 May, 2017 11:27 AM

I am having problems with encrypting and decrypting attachments between CryptUp and Apple Mail (GPG Suite). I tried to send and receive PGP-encrypted attachments between these two systems with two different email addresses:

  1. Windows 10 / Chrome / Gmail / CryptUp Plugin
  2. Mac OS Sierra / Apple Mail / GPG Suite

Sending encrypted emails (text only) between the two systems works fine.
Sending encrypted emails with attachments from AppleMail (GPG Suite) to Gmail (CryptUp) works fine.
Sending encrypted emails with attachments form Gmail (CryptUp) to Apple Mail (GPG Suite) does not work. The attachments are not being decrypted by GPG Suite and appear as .pgp files attachments that cannot be opened. I have to save them manually to the download folder and decrypt them by using GPGServices: OpenPGP Decrypt:File.

Expected
I expected that attachments are being decrypted automatically by GPG-Suite and can be opened directly from apple mail. I am wondering if GPG-Suite is using the proper “decryption method" since the original views of the emails sent with CryptUpt an sent with GPG Suite look quite differently.

Additional info
If you could help me with this, it would be great. Encrypted communication between Windows and Mac and between Gmail an Apple Mail is exactly what I need.

macOS           10.12.4     16E195
GPG Suite       2017.1b3    1812    (d43863c)
GPGMail         2.7b3       1215    (d0b5fa0)
GPG Keychain    1.3.3b2     1271    (028a4a2)
GPGServices     1.11        916     (872e77d)
MacGPG2         2.0.30-1b2  887-    (4912d26)
GPGPreferences  2.0.2b3     927     (641418e)
Libmacgpg       0.7         782     (536bf51)
pinentry        0.9.7       4       (b75069d)
  1. 1 Posted by Tom James Holub on 01 May, 2017 01:33 PM

    Tom James Holub's Avatar

    Tom here, the guy who created CryptUp. My software is sending attachments as standard attached files that hava ".gpg" added and are encrypted/saved in binary form without ascii armor, the way GPG would do it. Let me know what can we do to make GPG Suite recognize these.

    Cheers,
    Tom

  2. 2 Posted by Daniel Zimmerma... on 02 May, 2017 07:07 PM

    Daniel Zimmermann's Avatar

    Here comes a sceenshot illustrating the problem....

  3. Support Staff 3 Posted by Steve on 03 May, 2017 03:05 PM

    Steve's Avatar

    Hi Daniel,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Thanks for taking the time to report this problem. And thanks Tom for chiming in on this. We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news. Feel free to open a new discussions should you run into further problems or need assistance.

    A fix is in the works already and will likely be included in the upcoming next beta.

    To manually decrypt the attachment, please drag the attachment to your desktop and double click the file. That should open GPGServices. Or try right-clicking > Services > OpenPGP: Decrypt file.

    All the best,
    steve

  4. 4 Posted by Tom James Holub on 03 May, 2017 03:08 PM

    Tom James Holub's Avatar

    Thanks for the heads up Steve, that's great news.

  5. 5 Posted by Daniel Zimmerma... on 04 May, 2017 07:18 PM

    Daniel Zimmermann's Avatar

    Success! Sucess! Let's see what the guys from GPG-Tool will do about a fix in
    the next beta release..... Greets, Daniel

  6. Support Staff 6 Posted by Steve on 08 May, 2017 08:59 AM

    Steve's Avatar

    Thanks for the feedback. Closing this discussion for now. We'll re-open as soon as we have news.

  7. Steve closed this discussion on 08 May, 2017 08:59 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac