GPG Keychain: Can't Export Keys

Timothy Monnig's Avatar

Timothy Monnig

09 Apr, 2017 09:01 PM

When I try to export keys to the HDD. I get an error - after updating to Newest sierra patch - 10.12.4 (16E195) MacOS:
Key export failed.
Export failed!
Code = 0

Error text:
gpg: [don't know]: indeterminate length for invalid packet type 13
gpg: key export failed: Invalid packet

For it to work - export to file like always. What happened or caused this error I do not know or how to fix it.

macOS           10.12.4     16E195
GPG Suite       2017.1b3    1812    (d43863c)
GPGMail         2.7b3       1215    (d0b5fa0)
GPG Keychain    1.3.3b2     1271    (028a4a2)
GPGServices     1.11        916     (872e77d)
MacGPG2         2.0.30-1b2  887-    (4912d26)
GPGPreferences  2.0.2b3     927     (641418e)
Libmacgpg       0.7         782     (536bf51)
pinentry        0.9.7       4       (b75069d)
  1. Support Staff 1 Posted by Steve on 10 Apr, 2017 09:28 PM

    Steve's Avatar

    Hi Timothy,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    How are you exporting the keys? Are you seeing the error with all keys you are trying to export or only some or one specific key?

    All the best,

  2. 2 Posted by Timothy Monnig on 11 Apr, 2017 12:43 AM

    Timothy Monnig's Avatar

    How I fixed it was to back-up the old folder, re-install the 2017.b3 (MAC)
    then I opened the file-
    pubring.gpg - as GPG keyring. Then I was able to Export the keys again.
    Not sure what caused this issue, but this is how I fixed it.

  3. Support Staff 3 Posted by Steve on 11 Apr, 2017 09:09 AM

    Steve's Avatar

    OK thanks for sharing your solution. Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  4. Steve closed this discussion on 11 Apr, 2017 09:09 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac