Mail forward changes email address

Istvan's Avatar


24 Mar, 2017 02:02 AM

Hi Guys,

First of all thanks a million for the new 2017.1b3 beta. I tried it and works nice :-) However, I found some issues what might be worth for you to know. I had the feeling that these are interrelated so I opened only one ticket but there are chances that I'm wrong... Will see.

So I just upgraded to Beta 3. From that on the behaviour of Mac Mail changed. I have multiple email addresses set up in Mail. When I receive a mail to my mail address "A" and I forward it to someone then I expect that the sender of that mail will be "A". However in several cases the sender email address changes to address "B".

On a random way GPGmail asks for password. It is not in line with my activity. Previously it asked for the password only when I wanted to use a certificate (wanted to send or open an encrypted mail). It seems that some background processes are trying to process encrypted messages (?). Sending read receipts encrypted (?) or saving open draft messages periodically in a secure way even though they are not intended to be encrypted (?).

The versions of GPG Keychain and MacGPG2 are b2 instead of b3. So there might be some version mismatch in the installation package. This looks a cosmetic issue but better to know it... GPGKeychain/About reports version 1.3.3b2. In Finder the GPGKeychain/Get info reports the same version 1.3.3b2. However, when I select function Check for Updates then a message displayed: GPGSuite 2017.1b3 is currently the newest version available.

If I can do any further testing please let me know. I'm more than happy to do it so.


Forward the mail with sender address "A" (the incoming mail's recipient).

macOS           10.12.3     16D32
GPG Suite       2017.1b3    1812    (d43863c)
GPGMail         2.7b3       1215    (d0b5fa0)
GPG Keychain    1.3.3b2     1271    (028a4a2)
GPGServices     1.11        916     (872e77d)
MacGPG2         2.0.30-1b2  887-    (4912d26)
GPGPreferences  2.0.2b3     927     (641418e)
Libmacgpg       0.7         782     (536bf51)
pinentry        0.9.7       4       (b75069d)
  1. Support Staff 1 Posted by Luke Le on 24 Mar, 2017 02:12 AM

    Luke Le's Avatar

    Hi Istvan,

    very sorry to hear you're having problems with our tools.
    It's possible that the account switching you're seeing is not related to GPGMail, but to test that theory, you would have to temporarily uninstall it (Move the bundle from /Library/Mail/Bundles to somewhere else).
    In Sierra, Apple implemented some kind of intelligent account switching. We believe it's based on the last account used, but couldn't determine exactly when which account is chosen.

    All drafts are encrypted by default, which is probably the reason why you're being asked for your passphrase. You could either disable draft encryption in Mail -> Preferences -> GPGMail -> untick Encrypt drafts or adjust your passphrase caching time in System Preferences -> GPGPreferences.

    If neither of those two solutions work, it's still very much possible that you've discovered a bug.

    In general, we've made extra sure that PGP operations always one happen if you've actively selected a message or are composing a message (to decrypt the encrypted drafts).

    Hope that helps.

  2. 2 Posted by IIK on 24 Mar, 2017 03:03 AM

    IIK's Avatar

    Hi Luke,

    Thanks for your fast reply! I made a bit of further testing based on your advice. Here are the findings:

    1. In /Library/Mail folder there are two folders. "Bundles" and "Bundles (disabled)". Both of them has only one file inside: GPGMail.mailbundle. They seems to be identical.

    2. I removed both the bundles. Restarted Mail. Checked that the GPG section disappeared from Mail/Preferences. The strange forward address issue is still there. The GPG password issue obviously gone.

    3. What I noticed with a closer look is that the sender's address is O.K. when I push the forward button. However, when I select the recipient address then the sender's address is changing.

    4. If I forward a message and start changing the recipient address on it then the sender's address is changing also. Really not that easy to find any logic behind. Quite random.

    So I guess we found a bug but in OSX Mail. I will test a bit more the underlying logic - if I manage to find out something then I will let you know.

    Thanks again,

  3. Support Staff 3 Posted by Steve on 27 Mar, 2017 07:31 PM

    Steve's Avatar

    Hey Istvan,

    thanks for the update. This issue is not related to GPG Suite. It sounds a lot like you are seeing a new feature from apple, which they did not mention in any changelog for whatever philosophical reasons they may have to not provide those.

    Please open > Preferences > Composing > Adressing: and for the item "Send new messages from:" check if you have "Automatically select best account" selected.

    All the best,

  4. Support Staff 4 Posted by Steve on 24 May, 2017 05:12 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  5. Steve closed this discussion on 24 May, 2017 05:12 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac