GPGMail: "Unknown system error" decrypting a message in Mac Mail

Josh Fleming's Avatar

Josh Fleming

16 Mar, 2017 12:12 PM

On the latest message of a thread, it refuses to decrypt the message, and I get the following error:

gpg: decrypt_message failed: Unknown system error

All previous messages decrypt fine. When I download and manually decrypt this message from the command line, that also works fine. It's only failing from within Mail. Also, this message actually decrypted the first time I read it. It was only when I came back that it started failing to decrypt.

Note: The versions shown in the attachment are the latest nightlies, but I've also tried beta 2, and that didn't work either.

What did you expect instead

Message should decrypt within Mail.

Describe steps leading to the problem.

Open Mail and click the thread.

No other plugins

  1. Support Staff 1 Posted by Steve on 16 Mar, 2017 12:23 PM

    Steve's Avatar

    Hey Josh,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    The problem you are seeing is with a single message or with any newest message in any threaded view?

    Are you able to reproduce the problem by sending yourself 2-3 mails with the same subject?

    All the best,

  2. 2 Posted by Josh Fleming on 16 Mar, 2017 12:44 PM

    Josh Fleming's Avatar

    Just tried that. Here's what happened:

    1. Sent myself a message. This worked fine.
    2. Sent myself a second message in the thread. Also worked fine.
    3. Sent myself a third message. Things got a little strange here. At first, the message appeared, but only with the version and "ecrypted.asc" attachments and no error message. I closed and reopened Mail. Now the message was gone entirely. Closed and reopened Mail again a few times. Message finally appeared decrypted.
    4. Same thing happened on the fourth message.

    So it seems I can't reproduce the original problem by sending myself messages this way. There is something strange going on as a thread grows in size, though. The original failure I'm seeing is on the fourth message in the thread.


  3. Support Staff 3 Posted by Steve on 16 Mar, 2017 12:57 PM

    Steve's Avatar

    Josh, what you are seeing is a known issue, we are currently working on.

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news. Feel free to open a new discussions should you run into further problems or need assistance.

    All the best,

  4. 4 Posted by Josh Fleming on 16 Mar, 2017 01:18 PM

    Josh Fleming's Avatar

    Great, thanks!


  5. 5 Posted by Josh Fleming on 16 Mar, 2017 01:40 PM

    Josh Fleming's Avatar


    An update. I tried opening the original broken thread in Mozilla Thunderbird + Enigmail. Enigmail complained that the message had a broken MS-Exchange envelope, or something like that, and gave me the option to "repair" the message. After I did that, it decrypted correctly in both Thunderbird/Enigmail and Mail/GPGMail.


  6. Support Staff 6 Posted by Steve on 17 Mar, 2017 12:00 PM

    Steve's Avatar

    Josh, thanks for the update. That is interesting news.

    We would like to look into this in greater detail. For that, there's a few things to clarify:

    For now, let's focus on the problem in regards to the message which you report Enigmail managed to repair. Are you able to reliably reproduce the initial issue? That would mean, could you ask the author of the problematic message to send another test message your way. Then inspect the new message in GPGMail and check if the problem again is showing.

    If that is the case, it would be really helpful, to get our hands on such a message (identically structure of course) in our own inbox. So then, could you ask the author to send a test mail our way: team AT gpgtools DOT org

    Oh and it would also be interesting to know, if enigmail again manages to repair that message and if after repair that message also correctly is displayed in GPGMail.

    Screenshots of the way GPGMail displays the message in question before and after repair would be very helpful as well.

    Thanks for your help and further investigation to debug this case.


  7. Support Staff 7 Posted by Steve on 19 Mar, 2017 11:56 PM

    Steve's Avatar

    Please re-test using the latest nightly build from

  8. 8 Posted by Josh Fleming on 20 Mar, 2017 12:41 PM

    Josh Fleming's Avatar

    Hi Steve,

    Sorry, I was never able to reproduce this problem after "repairing" that one message with Enigmail. However I can confirm that the latest GPGMail nightly still decrypts new "un-repaired" messages properly.

    Taking a look at the un-repaired and repaired messages, the only difference I see is that MS-Exchange seems to be adding a "text/plain" part to the beginning of the message, e.g.:

    Content-Type: text/plain; charset="us-ascii"
    Content-Transfer-Encoding: quoted-printable

    Enigmail removes this when it repairs the message. There's some discussion about it here:

    However I'm not sure that this is what caused the failure in GPGMail Beta 2, since it decrypted these messages fine before the one offending message, and it's decrypting the new ones fine also.



  9. Support Staff 9 Posted by Steve on 20 Mar, 2017 03:44 PM

    Steve's Avatar

    Alright, let's call this case closed. We are still working on issues with the current nightly and hope to have the next beta ready once those are solved.

    Thanks a lot for your feedback.

    I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  10. Steve closed this discussion on 20 Mar, 2017 03:44 PM.

  11. Support Staff 10 Posted by Steve on 22 Mar, 2017 09:40 PM

    Steve's Avatar

    Just for your info: GPG Suite 2017.1b3 which fixes a ton of issues has just been released.

    All the best,

  12. Steve closed this discussion on 22 Mar, 2017 09:40 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac