GPGMail: Messed up flagged mails counter

Stefan's Avatar


03 Mar, 2017 03:53 PM

I have 2 flagged emails. When I click on the flagged mails filter I see three mails though. Two are actually flagged. One is not but still in there. It does not help to flag / unflag any of them. They stay in there. Also I see “Flagged (6)” as the title of my flagged mails filter. So Mail thinks there should be 6 mails in there. Even more weird.

I expect the flagged mails counter to match the actual flagged emails.
I expect the flagged mails filter to only contains mails which are actually flagged.

macOS           10.12.3     16D32
GPG Suite       2017.1b2    31b 
GPGMail         2.7b2       1192b
GPG Keychain    1.3.3b1     1249b
GPGServices     1.11        916 
MacGPG2         2.0.30-1b2  887-
GPGPreferences  2.0.2b2     912b
Libmacgpg       0.7         775 
pinentry        0.9.7       4
  1. Support Staff 1 Posted by Steve on 16 Mar, 2017 01:10 PM

    Steve's Avatar

    Hey Stefan,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you temporarily disable GPGMail:

    • shut down
    • open finder
    • navigate to /Library/Mail/Bundles or ~/Library/Mail/Bundles and copy GPGMail.mailbundle to your desktop
    • now delete GPGMail.mailbundle from the original folder

    Restart mail and check in > Preferences if you still see GPGMail. It should be gone.

    To re-enable mail, close and move the bundle file back to the Bundles folder.

    Does the problem persist after disabling GPGMail?

    All the best,

  2. Support Staff 2 Posted by Steve on 24 May, 2017 04:35 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  3. Steve closed this discussion on 24 May, 2017 04:35 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac