GPGMail: problems using S/MIME on macOS 10.12.3

Wojciech's Avatar


30 Jan, 2017 02:09 PM


I have the following problems with GPGMail under macOS 10.12.3 with Mail app:

  1. I’m using S/MIME certs as well and there is no option to configure the default sign for all the messages (preffered sign is PGP and there no option to change to S/MIME).
  2. if I try to send the message signed with PGP but finally I will change to S/MIME, the message is sending but the window with compose message does not hidden (in the SENT box I see sended message but manualy I have to close the window).

fix it :)

macOS           10.12.3     16D32
GPG Suite       2017.1b2    31b 
GPGMail         2.7b2       1192b
GPG Keychain    1.3.3b1     1249b
GPGServices     1.11        916 
MacGPG2         2.0.30-1b2  887-
GPGPreferences  2.0.2b2     912b
Libmacgpg       0.7         775 
pinentry        0.9.7       4
  1. Support Staff 1 Posted by Steve on 20 Feb, 2017 03:49 PM

    Steve's Avatar

    Hey Wojciech,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Problem #2 is already fixed. Could you please download and install our latest GPG Suite nightly build and see if the problem persists. That page also has sig and SHA1 to verify the download.

    To adjust the default signing method, this KB-article explains how to activate this setting.

    Let me know if that did the trick.

    All the best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. Support Staff 2 Posted by Steve on 04 May, 2017 02:04 PM

    Steve's Avatar

    A fix for this problem was release with GPG Suite 2017.1b3.

  3. Steve closed this discussion on 04 May, 2017 02:04 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac