GPGMail: Mail crashes -> GPGMail for macOS 10.12 Sierra (Beta 1)

Jesse's Avatar

Jesse

19 Jan, 2017 12:40 PM

This comment was split from the discussion: GPGMail: Mail crashes -> GPGMail for macOS 10.12 Sierra (Beta 1)

I am seeing the same issue for one of the users i manage. It originally crashed anytime you tried to do a new email, reply, or forward. I did an in place reinstall of the OS as nothing I tried by way of resetting mail or GPGTools would yield any different results. After the OS reinstall Mail no longer crashed but rather did nothing visually when you would try to compose, reply, or forward. It does however create a draft every time you do one of those actions. If you try to open it from within the drafts area a window comes up that can't be sent, closed, or typed into on the message body.

  1. Support Staff 1 Posted by Steve on 19 Jan, 2017 12:43 PM

    Steve's Avatar

    Hey Jesse,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Whenever you need assistance with GPG Suite, please create a new discussion. While it is common on other forums to join existing discussions with similar or identical problems, for the GPGTools support forum, this is not a good idea. Having many users in one discussion is likely to cause confusion, thus it's best to solve issues on a "per case" basis. That helps to keep the discussion straight forward and provide a fast solution to you and other users.

    I have thus split your comment into a separate discussion.

    Regarding the behaviour you are seeing: Could you send a debug log from within GPGPreferences > Send report from the affected machine. Add a link to this discussino here so we know what the debug log is about.

    Could you temporarily disable GPGMail:

    • shut down mail.app
    • open finder
    • navigate to /Library/Mail/Bundles or ~/Library/Mail/Bundles and copy GPGMail.mailbundle to your desktop
    • now delete GPGMail.mailbundle from the original folder

    Restart mail and check in Mail.app > Preferences if you still see GPGMail. It should be gone.

    To re-enable mail, close Mail.app and move the bundle file back to the Bundles folder.

    After disabling GPGMail are you able to work with Mail.app as expected?

    All the best,
    steve

  2. 2 Posted by Jesse on 19 Jan, 2017 02:26 PM

    Jesse's Avatar

    Sorry, I'd thought i'd posted this in this thread https://gpgtools.tenderapp.com/discussions/beta-feedback/1268-gpgma...

    I have uninstalled and reinstalled the plugin to no avail. Whenever GPGTMail is installed no message composition windows can be created. When it is not installed, everything is fine.

  3. Support Staff 3 Posted by Steve on 19 Jan, 2017 03:05 PM

    Steve's Avatar

    Should you be available, could you hop on our live chat here:
    https://www.hipchat.com/gi8zHW4K3

    We can't promise a solution, but we'd like to inspect this problem in more detail.

    All the best
    steve

  4. Support Staff 4 Posted by Steve on 19 Jan, 2017 09:44 PM

    Steve's Avatar

    Jesse spent some time to debug this and did an outstanding job!

    Here's the findings, which led to a working state.

    1.Open System Preferences > Internet Accounts
    2. Add a new email account
    3. Launch Mail and open Mail > Preferences
    4. Under the Composing tab change the "Send new messages from" setting to the new account you just added
    5. Quit and relaunch Mail
    6. Try composing a new encrypted message
    7. If it works, at this point you can change the "Send new messages from" setting back to your default account.
    8. DO NOT delete the newly added account as this will cause the issue to reappear.

  5. 5 Posted by Jesse on 19 Jan, 2017 09:47 PM

    Jesse's Avatar

    To be clear, I am fully aware of how janky a workaround this is, but it worked under test conditions and on the production machine. I do not know what this is impacting directly, but it most likely is something at a deeper level based around how keychain and account communicate when composing new messages and creating drafts. That is just my guess though.

  6. Support Staff 6 Posted by Steve on 20 Jan, 2017 07:56 AM

    Steve's Avatar

    I wondered what would happen if you removed all accounts and re-added only the problematic account.

    That would be an interesting test to see if this gets rid of something that is stuck with the mail.app account settings.

  7. 7 Posted by Jesse on 20 Jan, 2017 07:59 PM

    Jesse's Avatar

    Doing this does not work. Another reason why this solution is stupid.

  8. Support Staff 8 Posted by Steve on 22 Feb, 2017 04:41 PM

    Steve's Avatar

    Jesse, could you please download and install our latest GPG Suite nightly build and see if the problem persists. That page also has sig and SHA1 to verify the download.

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  9. Support Staff 9 Posted by Steve on 19 Mar, 2017 11:22 PM

    Steve's Avatar

    Hi Jesse,

    the issue with Mail Act-On and GPGMail has been fixed. If you want to test the fix, please download our latest nightly GPG Suite. That page also has sig and SHA1 to verify the download.

    Should the problem persist, please re-open this discussion and let us know. For more questions that are not related to this specific problem, you are welcome to create a new discussion any time.

    Best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  10. Steve closed this discussion on 19 Mar, 2017 11:22 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac