GPGMail: New mail not encrypted

Hilario Ortigosa's Avatar

Hilario Ortigosa

14 Jan, 2017 09:00 PM

I can sign the email and see the signed and / or encrypted mail, but the email is sent unencrypted, even if the encryption button was selected. I tried to send it with and without the 'sign' button selected (the email is sent correctly signed when it should)

Mail sent encrypted when it should to

macOS           10.12.2     16C67
GPG Suite       2016.12b1   26b 
GPGMail         2.7b1       1179b
GPG Keychain    1.3.3b1     1249b
GPGServices     1.11        916 
MacGPG2         2.0.30      884 
GPGPreferences  2.0.2b1     908b
Libmacgpg       0.7         775 
pinentry        0.9.7       4
  1. 1 Posted by john.t.hoffoss on 16 Jan, 2017 03:55 PM

    john.t.hoffoss's Avatar

    I had a similar issue. Do you by chance have another Mail plugin installed, like Mail Act-On for example? When I disabled Mail Act-On, GPG then encrypted messages as expected.

  2. 2 Posted by Hilario Ortigos... on 16 Jan, 2017 07:54 PM

    Hilario Ortigosa's Avatar

    You're right, I have several Mail plugins, and encryption works well when I disable mail act-on. I need it enabled, but at least the problem origin is located.

  3. Support Staff 3 Posted by Luke Le on 16 Jan, 2017 09:54 PM

    Luke Le's Avatar


    thank you very much for this valuable information.
    We know the people developing Act-On and will get in touch with them.

  4. 4 Posted by sky on 18 Jan, 2017 08:43 PM

    sky's Avatar

    I can verify that Mail Act-On is causing a conflict. I uninstalled it and now my GPGMail encrypts properly.

  5. Support Staff 5 Posted by Steve on 18 Jan, 2017 08:44 PM

    Steve's Avatar

    Thanks for the feedback, sky.

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news. Feel free to open a new discussions should you run into further problems or need assistance.

  6. 6 Posted by john.t.hoffoss on 18 Jan, 2017 11:24 PM

    john.t.hoffoss's Avatar

    Steve, you can link this thread too:

    Please note you can just disable the Mail Act-On plugin as I describe in that thread.

  7. Support Staff 7 Posted by Steve on 18 Jan, 2017 11:26 PM

    Steve's Avatar

    Done, thanks for pointing that out. And yes, temporarily disabling Mail Act-On will bring you a working GPGMail. We still have to look into the specifics to solve this problem.

  8. 8 Posted by sky on 12 Feb, 2017 04:56 AM

    sky's Avatar

    Just confirmed that Mail Act-On 4.0.3 released recently does -not- fix the problem.

  9. Support Staff 9 Posted by Steve on 19 Mar, 2017 11:20 PM

    Steve's Avatar

    Hi Hilario and all,

    this issue has been fixed. If you want to test the fix, please download our latest nightly GPG Suite. That page also has sig and SHA1 to verify the download.

    Should the problem persist, please re-open this discussion and let us know. For more questions that are not related to this specific problem, you are welcome to create a new discussion any time.

    Best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  10. Steve closed this discussion on 19 Mar, 2017 11:20 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac