GPGMail: Beta: Attention - the signature of this message is invalid

Bernhard Waldecker's Avatar

Bernhard Waldecker

02 Jan, 2017 10:37 PM

Hi,

i installed the beta and tried it on MacOS
pub 4096R/4F04AC10 2014-01-11 Bernhard Waldecker [email blocked]

I sent a mail to my own mailbox and got the following feedback:
ATTENTION: The signature of this message is invalid!
This message might have been modified after the signature was created.

Please contact the sender to make sure the content of the message matches the original.

Please contact us at
https://gpgtools.tenderapp.com/
if you're sure the message was not modified.

Or did i miss any checkbox?

Regards

Expected
Like in the version before: valid signature

macOS           10.12.2     16C67
GPG Suite       2016.12b1   26b 
GPGMail         2.7b1       1179b
GPG Keychain    1.3.3b1     1249b
GPGServices     1.11        916 
MacGPG2         2.0.30      884 
GPGPreferences  2.0.2b1     908b
Libmacgpg       0.7         775 
pinentry        0.9.7       4
  1. 1 Posted by McFate on 03 Jan, 2017 12:33 AM

    McFate's Avatar

    This comment was split into a new discussion: GPGMail: Beta: Attention - the signature of this message is invalid

    I'm seeing exactly the same problem: the new (beta) version of GPGTools signs and encrypts stuff without complaining, but then fails with an "unknown error" when checking the signature or decrypting the message.

  2. 2 Posted by drim498 on 03 Jan, 2017 03:00 AM

    drim498's Avatar

    I've run into the same issue, here's some more info of what I've found so far, tested by sending emails from one account to others of mine (I have 4)

    It shows as invalid in the sent box, but the inbox shows as a valid signature, regardless of which account I sent from or to.

    If I encrypted the message as well as signed it, the signature shows as valid in the sent box.

    So basically, it's only unencrypted emails that are showing as invalid signatures in the sent box. Everything else is working as expected so far.

    I've attached screen shots of the error messages. I can include any other info you need, just let me know

  3. 3 Posted by Alexander on 03 Jan, 2017 08:11 AM

    Alexander's Avatar

    Same problem: Invalid Signature in outbox. I was wondering if this was a result of having recently installed X509 Certs for S/MIME, and the message was being modified by that signature (I'm not clear if both signatures are applied, and if so, what order).

  4. 4 Posted by Jeff Gardner on 04 Jan, 2017 04:17 PM

    Jeff Gardner's Avatar

    I am getting the same issue. However, I am getting the invalid signature warning in messages in my Inbox. My Sent folder shows the same message but with valid signatures. I tested by sending signed email to myself. Signed+Encrypted looks OK to me. Signed only I see invalid signature.

  5. 5 Posted by bernhard on 04 Jan, 2017 07:56 PM

    bernhard's Avatar

    i can also confirm: Sign + Encrypt: everything looks fine in the inbox and sent folder
    only sign: i'm getting the warning - in the inbox and the sent folder

  6. 6 Posted by Carlos Família on 05 Jan, 2017 11:38 AM

    Carlos Família's Avatar

    I have the same problem. Any solution yet?

  7. 7 Posted by marty on 10 Jan, 2017 04:18 PM

    marty's Avatar

    the same problem

  8. 8 Posted by KZeni on 16 Jan, 2017 08:27 PM

    KZeni's Avatar

    Same problem here (running GPGSuite 2016.12b1 on latest OS X 10.12.3 beta).

  9. 9 Posted by BXIA on 17 Jan, 2017 03:44 AM

    BXIA's Avatar

    Same problem here.

  10. Support Staff 10 Posted by Steve on 18 Jan, 2017 07:51 PM

    Steve's Avatar

    Hi all,

    thanks for the feedback about GPGMail beta for macOS Sierra 10.12.

    We think we fixed the problem you are seeing. Could you please install GPG Suite from our nightlies page and see if the problem then persists.

    Looking forward to your feedback.

    All the best,
    steve

  11. 11 Posted by drim498 on 18 Jan, 2017 08:00 PM

    drim498's Avatar

    Just updated to the latest nightly build and can confirm that my issue with the signature is fixed.

  12. 12 Posted by Jeff Gardner on 18 Jan, 2017 08:02 PM

    Jeff Gardner's Avatar

    I tried this new nightly and for me it does not fix the problem. Maybe the nightly didn't get an updated GPGMail because my preferences says: Version 2.7b1 (5de17ba) Build: 1189n.

    I quit Mail.
    Opened .dmg file and ran the Install.
    Started Mail.
    No noticeable changes.
    Quit mail again.
    Ran Uninstall.
    Opened Mail, verified its not installed.
    Quit Mail
    Ran Install again.
    Started Mail.

  13. Support Staff 13 Posted by Steve on 18 Jan, 2017 08:06 PM

    Steve's Avatar

    Jeff, could you hop on our live chat:
    https://www.hipchat.com/gi8zHW4K3

  14. 14 Posted by tom on 18 Jan, 2017 09:14 PM

    tom's Avatar

    Steve,

    This build fixes the problem for me. Thx!

    Tom

  15. Support Staff 15 Posted by Steve on 18 Jan, 2017 10:42 PM

    Steve's Avatar

    Great. After received positive feedback from three independent users, I'll go ahead and close this discussion.

    Glad, this is solved for you. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  16. Steve closed this discussion on 18 Jan, 2017 10:42 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac