GPGMail: Invalid signature on email I just created and signed using MacGPG Beta for Sierra

Fred Baker's Avatar

Fred Baker

17 Jan, 2017 10:57 PM

Just created a new key for this email address using beta MacGPG/Sierra software. Sent an email signed using it. Apple Mail (Sierra) tells me that the signature is invalid. It should be correct if I created the email...

I expected the signature on an email I just created using a key just created to be valid.

macOS           10.12.2     16C67
GPG Suite       2016.12b1   26b 
GPGMail         2.7b1       1179b
GPG Keychain    1.3.3b1     1249b
GPGServices     1.11        916 
MacGPG2         2.0.30      884 
GPGPreferences  2.0.2b1     908b
Libmacgpg       0.7         775 
pinentry        0.9.7       4
  1. Support Staff 1 Posted by Steve on 18 Jan, 2017 05:32 PM

    Steve's Avatar

    Hey Fred,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Thanks for the feedback about GPGMail beta for macOS Sierra 10.12.

    We think we fixed the problem you are seeing. Could you please install GPG Suite from our nightlies page and see if the problem then persists.

    Looking forward to your feedback.

    All the best,

  2. 2 Posted by Fred Baker on 18 Jan, 2017 05:48 PM

    Fred Baker's Avatar

    The symptom I reported, that it would say that a message I had just created had an invalid signature, seems to be fixed. Thanks.

    I have another thing bugging me now, though. I'm a consultant, and have several email addresses, and keys for most of them. One, the address I use as primary, I have forgotten the passphrase for and need to replace. This address is a relatively new one. I observe some odd behavior among the addresses, and I'm not sure whether that is Apple Mail or GPG. So let me tell you, and you can tell me I'm looking in the wrong place.

    Several times, inconsistent but more or less repeatable, I have started creating a test email using this address, assuming the signature would be for this address. The tool has changed source addresses for me, and asked me for the passphrase for my primary address. When I convince it to stop bugging me for the passphrase and can actually see the email, I observe that the "from" address has changed.

    Is that an Apple Mail misfeature? I haven't observed it before - and have been using Apple Mail and GPG for most of 22 years.

  3. Support Staff 3 Posted by Steve on 18 Jan, 2017 06:28 PM

    Steve's Avatar

    Great, thanks for the quick feedback.

    We think that what you are seeing is an apple bug. Please use their feedback form to let them know about this problem:

    Could you temporarily disable GPGMail:

    • shut down
    • open finder
    • navigate to /Library/Mail/Bundles or ~/Library/Mail/Bundles and copy GPGMail.mailbundle to your desktop
    • now delete GPGMail.mailbundle from the original folder

    Restart mail and check in > Preferences if you still see GPGMail. It should be gone.

    To re-enable mail, close and move the bundle file back to the Bundles folder.

    Does the problem persist now?


  4. 4 Posted by Fred Baker on 18 Jan, 2017 09:06 PM

    Fred Baker's Avatar

    OK, I did not see the issue with GPG disabled, and now that I have re-enabled it, I don't see it. Mumble. I hate intermittent problems - better that it just be broken so it can "just" be described and fixed.

    Sorry to have bothered you. Thanks for fixing the original problem.

  5. 5 Posted by mpgagne on 18 Jan, 2017 09:16 PM

    mpgagne's Avatar


    I think this is an issue that has been confusing a few people in Sierra. The new tries to guess which of your multiple email addresses you like to email each contact from. This has had the effect of some sierra users inadvertently emailing people from the wrong From address. This would cause of you issue you are describing. It can be disabled in settings, but unfortunately, the classic behavior is no longer available. You must now choose between always selecting the default address or selecting a From address based on your history with that contact. It has caused more than one missfire on my part.

    I hope this is helpful.

  6. 6 Posted by Fred Baker on 18 Jan, 2017 09:17 PM

    Fred Baker's Avatar

    Very. Thanks.

  7. Support Staff 7 Posted by Steve on 18 Jan, 2017 10:26 PM

    Steve's Avatar

    Thanks mpgagne for pointing this out!

    The fact that switches the From: account after the recipient is entered in the To: field of a draft is a new feature of Mail version 10.x since macOS 10.12 Sierra. does remember from which account you previously wrote to that recipient and switches to that account, because it assumes you will want to use the same account again. That isn't such a bad idea. But the behaviour can be confusing, especially since Apple does not provide such changes in a proper changelog for

    Navigate to > Preferences > Composing and you will find an option 'Send new messages from: Automatically select best account'. You can switch that to a default account you would like to use instead. Or stick with the automatic selection, now that you know it's not a bug but a feature.


  8. 8 Posted by Fred Baker on 18 Jan, 2017 10:38 PM

    Fred Baker's Avatar

    Thanks. Yes, it's a feature not a bug. And it will be useful now that I understand it. I guess it would be nice if it posted a "growl" dialog like "I changed the account for your convenience", or provided a way that I could control it by policy such as "send messages to addresses from [email blocked]" or something like that. In any event, that's not your problem, it's just fallout.

  9. Support Staff 9 Posted by Steve on 18 Jan, 2017 10:39 PM

    Steve's Avatar

    Yes, as mentioned a proper changelog about such changes would come in handy as well.

    Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  10. Steve closed this discussion on 18 Jan, 2017 10:39 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac