GPGMail on El Capitan does not send signature inline (2.6b2 Build: 1105b) [Solution: restart so changes are reflected]

Patrick Gerken's Avatar

Patrick Gerken

25 Feb, 2016 08:43 AM


I've used the hidden setting to activate pgpInline:
$ defaults read org.gpgtools.gpgmail UseOpenPGPInlineToSend 1

But mails still aren't being signed inline :-(
I've tried with plain text and rich text mails.

  1. Support Staff 1 Posted by Steve on 29 Feb, 2016 04:44 PM

    Steve's Avatar

    Hey ,

    welcome to the GPGTools community support platform. Sorry you are having problems using GPG Suite.

    This worked in my test.

    So you followed our KB-article and pasted ' defaults read org.gpgtools.gpgmail UseOpenPGPInlineToSend' into the terminal?

    If yes, could you send us a test mail including a link to this discussion so we can assign the testmail correctly.

    All the best,

  2. 2 Posted by Patrick Gerken on 07 Mar, 2016 09:32 AM

    Patrick Gerken's Avatar

    Hello Steve,

    thanks for looking into it.
    When I tried to reproduce the issue, my mails were suddenly signed inline.
    My Shell history shows me that I did not mistype the hidden settings earlier.
    Since then I rebooted my machine.
    I suspected that the settings might be cached, so I tested this by setting inline attachments to false.
    After that, my mails still were inline signed.

    I did some more tests to see what needs to be done so that updates have an effect. It is enough to exit and start it again.

    Sorry, I could have tried this before bothering you.

  3. Support Staff 3 Posted by Steve on 07 Mar, 2016 12:24 PM

    Steve's Avatar

    Hey Patrick,

    thanks for the update. Not a problem at all. now contains a section addressing this important information.

    Glad, this is solved for you. I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  4. Steve closed this discussion on 07 Mar, 2016 12:24 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac