gpg: <<my key id>>: skipped: Unusable public key gpg: -&5: encryption failed: Unusable public key

James's Avatar


07 Dec, 2015 12:36 AM

I'm getting the same error message as and and apparently

In there's a comment saying:

In the key tab you will notice that the capabilities section only lists "sc". On the sub-key tab you'll notice that one subkey with the capability "e" which stands for encrypt is no longer valid. Hence you cannot encrypt anything using this public key.

Please ask the key owner to update the key.

In my case, the key that's being complained about is my own key. which I created within GPG keychain. It has no subkeys, but the main key is missing the "e" capability. I'd ask the owner to update the key, but the owner is me, and I don't know how to update the key.

  1. 1 Posted by ca-design on 09 Dec, 2015 02:27 PM

    ca-design's Avatar

    You can update your key in GPG Keychain. Doubleclick the key. A slider opens. There is a subkey button. Ctrl-click on the key and and click "change expiration date" in the submenu (I have a german version, so it may have another name) and change to a future date.

    Hope that helps.

  2. Support Staff 2 Posted by Steve on 09 Jan, 2016 04:59 PM

    Steve's Avatar

    Hi James,

    welcome to the GPGTools community support platform. Sorry you are having problems using GPG Suite.

    Did ca-design's suggestion work out for you?

    All the best,

  3. 3 Posted by David on 02 Feb, 2016 01:14 PM

    David's Avatar

    ca-design and Steve,

    I had exactly the error described by James and ca-design's solution worked. I didn't even notice the subkey tab previously...



  4. Support Staff 4 Posted by Steve on 02 Feb, 2016 04:26 PM

    Steve's Avatar

    Dave, thanks for adding your experience.

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll receive a notification. Feel free to open a new discussions should you run into further problems or need assistance.

    James, if you need further assistance, you can re-open this discussion any time.

    I'm closing it for now.

    All the best,

  5. Steve closed this discussion on 02 Feb, 2016 04:26 PM.

  6. Steve closed this discussion on 27 Aug, 2018 12:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac